Opened 9 years ago

Closed 4 years ago

Last modified 4 years ago

#5701 closed Bug (fixed)

[IE] SCAYT wrong status after enter key

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.4.1
Keywords: IE, HasPatch, Review? Cc: WebSpellChecker.net

Description

  1. Load the following content and selection in editor;
    <p>
    	wrong^spell</p>
    
    • Expected Result: The word is red-marked in wysiwyg mode.
  2. Press 'Enter' key at the cursor position;
    • Expected Result: The marker underline is removed immediately after key down (Firefox behavior).
    • Actual Result: The marker will remain for a while until next refresh happens.

Attachments (1)

5701.patch (901 bytes) - added by WebSpellChecker.net 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by WebSpellChecker.net

Keywords: CantFix added

IE browser doesn't fire the "keypress" event on 'Enter' key press, that's why it seems that we can't fix this issue.

comment:2 Changed 8 years ago by WebSpellChecker.net

Keywords: HasPatch Review? added; CantFix removed
Version: 3.4.1

It seems we have managed to fix this in plug-in, not in core. Here is patch. Please, review.

Changed 8 years ago by WebSpellChecker.net

Attachment: 5701.patch added

comment:3 Changed 5 years ago by Artur Delura

Last edited 4 years ago by Wiktor Walc (previous) (diff)

comment:4 Changed 4 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed

Unable to reproduce in CKEditor 4.4.7 / IE8.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy