Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5707 closed Bug (fixed)

SCAYT changes selection after 'Backspace' key

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version:
Keywords: IE Confirmed Cc: WebSpellChecker.net

Description

Environment

IE

Reproducing Procedures

  1. Load the following content and selection in editor;
    [line one]
    
  2. Press 'Backspace' once to delete the line text;
  3. Wait for SCAYT to refresh.
    • Actual Result: The selection now becomes text type selection with one space character wide.
    • Expected Result: The cursor blinks in an empty pargraph.

Change History (7)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: IE WorksForMe added; [IE] Confirmed removed
Milestone: CKEditor 3.4

I'm not able to reproduce it with IE8. Can you please give more details?

comment:2 Changed 9 years ago by Garry Yao

Wait for SCAYT to refresh.

Seriously, you'll have to wait for a while.
Another easier way to reproduce is to insert an "Horizontal Line" after clicking on "New Page".

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; WorksForMe removed
Milestone: CKEditor 3.4CKEditor 3.3

Ok, this is really reproducible. It's enough to delete all with BACKSPACE and wait.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.4

Postponing it a bit. This is to be fixed at the SpellChecker.net side, and will be dealt right after the 3.3. release.

comment:5 Changed 9 years ago by WebSpellChecker.net

The problem is fixed in SCAYT core on SpellChecker.net side.

comment:6 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: newclosed

WFM in trunk now.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy