Opened 12 years ago

Closed 12 years ago

#571 closed Bug (fixed)

Opera: Backspace is broken

Reported by: Frederico Caldeira Knabben Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Must have (possibly next milestone) Milestone: Opera Compatibility
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

The backspace keystroke behavior is completely broken.

Steps to Reproduce

  1. Load sample01.html;
  2. Place the cursor after the sample text and hit [Enter];
  3. Type "Test" and hit [Backspace] (wrong behavior);
  4. Hit [Backspace] some few times (wrong behavior).

Tested with Opera build 9418.

Attachments (1)

split_text_on_backspace.htm (630 bytes) - added by Hallvord R. M. Steen (Opera Software) 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Attachment: split_text_on_backspace.htm added

comment:1 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

My new attachment shows the problem. It is caused by the DOM modifications going on in FCKW3CRange.prototype._ExecContentsAction. Opera obviously invalidates some internal range representation when the text node the cursor is placed in is modified through the DOM, meaning the cursor will end up at the start of the text node.

I think what we do is fairly reasonable and that you should restore the cursor position in the document after such DOM modifications, but I'll assign to self for now and ask our developers if we can fix it since Firefox handles this test case so well..

comment:2 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

This is filed as Opera bug 271702

comment:3 Changed 12 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

The problem has been fixed in [718] on FCKeditor's side.

Also, #1095 is a dup of this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy