Opened 12 years ago

Closed 9 years ago

Last modified 8 years ago

#572 closed Bug (wontfix)

Opera & Safari: The xml output of the connectors isn't show in the tests

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Low Milestone:
Component: General Version: FCKeditor 2.5
Keywords: Safari Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

Safari doesn't apply a default stylesheet to an xml document http://bugs.webkit.org/show_bug.cgi?id=13807 so the output in the connectors/test.html is an empty page (although viewing the source of the frame shows the content)

I don't know if they will fix this problem for the Safari 3 final release, but if a Safari user tries to debug a problem with the connector and can't see anything he will feel very frustrated.

Attachments (1)

Wniosek_2010_09_01_2204.xml (27.4 KB) - added by Krzysztof Studnik 9 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Summary: Safari: The xml output of the connectors isn't show in the testsOpera & Safari: The xml output of the connectors isn't show in the tests

Ops, somehow I did miss that the same problem is present in Opera. I thought that it did work, but maybe I saw only an error message when debugging the connectors, but not the pretty print of a real XML document.

comment:2 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Cc: Hallvord R. M. Steen (Opera Software) added

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Priority: NormalLow

comment:4 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed Safari Opera added
Version: SVN

comment:5 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Version: SVNFCKeditor 2.5

comment:6 Changed 9 years ago by Krzysztof Studnik

Keywords: Safari removed
Version: FCKeditor 2.53.4.1 (SVN - trunk)

In Confirmed for Opera 10.61.3484, CKE 3.4.1 Trunk:

  • Open sample editor
  • switch to source editing mode
  • paste XML source from attached or any other XML
  • switch to "normal" view

Button for switching views became disabled, in console an exception is thrown:

JavaScript - http://nightly.ckeditor.com/latest/ckeditor/_samples/replacebyclass.html

Uncaught exception: RangeError: Maximum recursion depth exceeded
Error thrown at line 28, column 4859 in p(q):
    var v=this[s],w=v.apply(window,arguments);
called from line 28, column 2699 in <anonymous function: onElement>(q):
    t=s.filter(q,v);
called from line 27, column 4110 in <anonymous function: writeHtml>(m, n):
    if(!(p=n.onElement(p)))
called from line 27, column 2527 in <anonymous function: writeChildrenHtml>(p, q):
    this.children[r].writeHtml(p,q);
called via Function.prototype.apply() from unknown location in <anonymous function: writeChildrenHtml>(m, n):
    /* no source available */
called via Function.prototype.call() from unknown location in <anonymous function: writeHtml>(m, n):
    /* no source available */
called from line 27, column 2527 in <anonymous function: writeChildrenHtml>(p, q):
    this.children[r].writeHtml(p,q);
called via Function.prototype.apply() from unknown location in <anonymous function: writeChildrenHtml>(m, n):
    /* no source available */
called via Function.prototype.call() from unknown location in <anonymous function: writeHtml>(m, n):
    /* no source available */
called from line 27, column 2527 in <anonymous function: writeChildrenHtml>(p, q):
    this.children[r].writeHtml(p,q);

In chrome, switching between views is possible

Changed 9 years ago by Krzysztof Studnik

Attachment: Wniosek_2010_09_01_2204.xml added

comment:7 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Safari added
Resolution: wontfix
Status: confirmedclosed
Version: 3.4.1 (SVN - trunk)FCKeditor 2.5

This was a problem with FCKeditor 2.5, it doesn't have any relationship with the reported problem.

Anyway, this was expecting fixes by the Webkit and Opera teams and there's no real need to keep it open any longer as now there are no xml responses.

comment:8 Changed 9 years ago by Hallvord R. M. Steen (Opera Software)

Pasting the attached XML in source view gives me an apparently empty page when switching back. No exceptions or errors. Placing cursor in the page, it goes inside an enormous number of elements according to the status bar, so it looks correct so far.

Switching back to source view again, I see that the XML has been wrapped in DIV tags and somewhat mangled. Now, on second attempt to switch from source view to RTE, the exception is thrown..

Uncaught exception: RangeError: Maximum recursion depth exceeded Error thrown at line 236, column 3 in <anonymous function: writeChildrenHtml>(writer, filter) in file://localhost/e:/svn/CKEditor/trunk/_source/core/htmlparser/element.js:

CKEDITOR.htmlParser.fragment.prototype.writeChildrenHtml.apply( this, arguments );

comment:9 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

That recursion error is still a problem with O11/CK 3.5. I'm not sure whether to re-open this or report a new bug.

comment:10 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

BTW, the real problem is that CKEditor assumes the inserted markup is HTML, not XML. Hence it doesn't consider self-closing tags ( such as <tag /> ) closed. The document it ends up with has a very deep nesting structure, and when CKEditor tries to parse it after the second source view it turns out the structure is too deep for the parser or something like that. I don't know where the limit is, but I don't really think the limit is unreasonable.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy