Ticket #5711 (closed Bug: expired)

Opened 4 years ago

Last modified 4 years ago

Chrome: undo broken by newlines and SCAYT

Reported by: tobiasz.cudnik Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: General Version:
Keywords: Chrome Pending Cc: SpellChecker.net

Description

Chrome: undo broken by newlines and SCAYT.

Reproduce

  1. Start typing random text in empty editor.
  2. Create at least 2 lines (3 is better).
  3. Try to undo all changes.

Result

Removed is only last started line. Content blinks but is still present.

Expected

Editor contains content as in the beginning.

After disabling SCAYT, undo works as expected.

Attachments

5711.patch (933 bytes) - added by SpellChecker.net 4 years ago.

Change History

comment:1 Changed 4 years ago by fredck

  • Cc SpellChecker.net added

comment:2 Changed 4 years ago by SpellChecker.net

confirm

Changed 4 years ago by SpellChecker.net

comment:3 follow-up: ↓ 4 Changed 4 years ago by SpellChecker.net

Update on SpellChecker.net side and patch attached fix the problem. It seems that Chrome does not allow to modify object prototype by reference.

comment:4 in reply to: ↑ 3 Changed 4 years ago by garry.yao

  • Keywords Pending added

The problem vanishes for me on trunk. Replying to SpellChecker.net:

Update on SpellChecker.net side and patch attached fix the problem. It seems that Chrome does not allow to modify object prototype by reference.

Any evidence for saying this?

comment:5 Changed 4 years ago by SpellChecker.net

Can confirm that the problem resolved only by SCAYT core update. No patch required.

comment:6 Changed 4 years ago by tobiasz.cudnik

I can't reproduce this issue anymore (in both enterModes). Even without applying the patch.

comment:7 Changed 4 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy