Opened 9 years ago

Closed 9 years ago

#5712 closed Bug (fixed)

Chrome: enter in pre causes problems

Reported by: Tobiasz Cudnik Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Enter Key Version: SVN (CKEditor) - OLD
Keywords: Chrome Confirmed Cc: WebSpellChecker.net

Description

Chrome: enter in pre causes problems

Reproduce

  1. Use following content:
    <pre>f^oo</pre>
    
  2. Hit enter to create new line.

Result

  1. Instead of new line, space is created.
  2. Editor looses focus.
  3. After switching to source view and back to RTE, newline is there.

Expected

  1. Carret is moved to new line.
  2. Focus remains inside the editor.

Change History (11)

comment:1 Changed 9 years ago by Garry Yao

Component: GeneralUI : Enter Key
Keywords: Confirmed added
Version: SVN (CKEditor)

comment:2 Changed 9 years ago by Garry Yao

Cc: WebSpellChecker.net added

Affected by SCAYT.

comment:3 Changed 9 years ago by WebSpellChecker.net

confirm

comment:4 Changed 9 years ago by WebSpellChecker.net

We have dicovered that this problem is hard-to-resolve quickly. We propose to disable SCAYT for PRE for all browser except FF. We have implemented this in core, but still need to prepare update to plug-in to fire scayt.refresh() on format change.

comment:5 Changed 9 years ago by Garry Yao

What exactly does "disable SCAYT for PRE" means? That sounds strange for us, we don't understand the difficulty for you behind this.

comment:6 Changed 9 years ago by WebSpellChecker.net

We have reviewed the problem and found that the reason was in CSS style. The problem fixed by updated of SCAYT core on SpellChecker.net side.

comment:7 Changed 9 years ago by Garry Yao

The bug is still reproducible on trunk.

comment:8 Changed 9 years ago by WebSpellChecker.net

Please try to clear cache, exit browser and then try again. Seems that just clearing cache is not enough.

comment:9 in reply to:  7 Changed 9 years ago by Garry Yao

Replying to garry.yao:

The bug is still reproducible on trunk.

I have newline created, but editor looses focus.

comment:10 Changed 9 years ago by WebSpellChecker.net

Fixed by scayt core update on spellchecker.net side.

comment:11 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: newclosed

Fix is confirmed on trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy