Opened 7 years ago

Closed 7 years ago

#5717 closed Bug (fixed)

SCAYT options must be the first in the context menu

Reported by: Frederico Caldeira Knabben Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.1
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: HasPatch Cc: WebSpellChecker.net, comp615@…

Description

The SCAYT suggestions and all SCAYT relative options must be the first in the context menu. This is the common behavior on applications, like MS Word and Firefox.

Attachments (1)

5717.patch (1.2 KB) - added by Charlie 7 years ago.
Patch as described in #3, config option removed and SCAYT moved to top

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Garry Yao

Keywords: Pending added; Confirmed removed
Milestone: CKEditor 3.4

Hts a NOT SURE on this, cloning the desktop behavior here maybe inappropriate because native context menu could penetrate the app window while we have limited space for it, this will be important especially when editor is integrate into a small frame in host page.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; Pending removed
Milestone: CKEditor 3.4

This one has nothing to do with the size of the context menu, just with the order of items. Currently it's chaotic and not predictable.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.5

comment:4 Changed 7 years ago by Charlie

Cc: comp615@… added

There's already a config option for this: editor.config.scayt_contextMenuOntop

Solutions: 1) Do nothing 2) Change the setting to true by default 3) Remove the config and always make it on top

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

KISS: I would vote 3.

We can rethink it if people start complaining.

Changed 7 years ago by Charlie

Attachment: 5717.patch added

Patch as described in #3, config option removed and SCAYT moved to top

comment:6 Changed 7 years ago by Charlie

Keywords: HasPatch added

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:8 Changed 7 years ago by WebSpellChecker.net

The patch has been successfully tested by SpellChecker.net team.

comment:9 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_passed

comment:10 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5834].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy