Opened 7 years ago

Closed 7 years ago

#5735 closed Bug (fixed)

Incorrect cursor position when refocusing editor and cursor is in scrolled content

Reported by: Arne Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.2.1
Keywords: IE Cc:

Description

1.Click anywhere in editor

2.Scroll up/down, make the cursor disappear from the editor screen

3.Click elsewhere apart from editor area (but on same window)

4.Click anywhere in editor to get cursor focus back on editor

5.The cursor ends up at the clicked position but the content gets scrolled so position of the cursor in the content is wrong.

Observed on IE7 and IE8

Attachments (2)

5735.patch (2.2 KB) - added by Garry Yao 7 years ago.
5735_2.patch (2.5 KB) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by Arne

Keywords: focus cursor ie7 ie8 removed
Milestone: CKEditor 3.3

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added
Milestone: CKEditor 3.4

Confirmed with IE8.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

May be related to #5280.

Changed 7 years ago by Garry Yao

Attachment: 5735.patch added

comment:4 in reply to:  3 Changed 7 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Replying to fredck:

May be related to #5280.

Similar, the patch handles #5280 and this ticket in a row.

comment:5 Changed 7 years ago by phil

Is #5581 related? I have re-opened.

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: IE added; Confirmed IE? removed
Milestone: CKEditor 3.4CKEditor 3.5

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

There is still a problem remaining. When clicking the scrollbar, the editor selection get collapsed.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 5735_2.patch added

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5CKEditor 3.4
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: review_failedreview

Anticipating this one, due to #5280.

comment:9 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5742].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy