Opened 9 years ago

Closed 9 years ago

#5764 closed Bug (duplicate)

Link button puts URL to left of selected text

Reported by: Aren Cambre Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: Cc: aren@…

Description

If I select text, click the Link button, type a URL, and press Enter or hit OK, the link usually but not always is inserted into the body test just to the left of the selected text.

For example, if I select Hello, World! and try to link it to http://www.cnn.com, I'll end up with http://www.cnn.comHello, World! in the WYSIWYG view and <a href="http://www.cnn.com">http://www.cnn.com</a>Hello, World! in the HTML code. Occasionally, CKEditor will properly link the selected text but also link many words to the right of the selected text. Rarely, CKEditor will link correctly.

I can reproduce on Firefox 3.6.3, Google Chrome 5.0.375.55, and Internet Explorer 8 at http://ckeditor.com/demo. All browsers are running on Windows 7.

I am not the only one to experience this. See the Drupal WYSIWYG module bug reported at http://drupal.org/node/812872.

Change History (2)

comment:1 Changed 9 years ago by Aren Cambre

In into the body test just to the left, I meant text instead of test.

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: newclosed

I know this is an older ticket, but we're already dealing with this issue on #5780.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy