Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#5781 closed Bug (fixed)

[[FF]] We can't delete/backspace chars after a sequence of actions

Reported by: Satya Minnekanti Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.2
Keywords: Firefox IBM Cc: Damian, joek

Description (last modified by Frederico Caldeira Knabben)

To reproduce the defect:

  1. Open Ajax sample.
  1. Type a single character 'a' and then press Backspace 2 times.
  1. Press Undo or Ctrl + Z to get the character back.
  1. Now try to delete the Character using Delete or Backspace

Expected Result:

User should be able to delete the Character using Delete or Backspace

Actual Result:

We can't delete the Character no matter how many no of times we press Delete.

We were able to delete the Character only when we type some new character

Attachments (2)

5781.patch (3.4 KB) - added by Garry Yao 7 years ago.
5781_2.patch (3.5 KB) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Confirmed Firefox added

Confirmed with Firefox. Works well with IE.

This is clearly a browser bug. I'm sure we've faced something similar in the past.

Other than fixing it at our side, it would be useful to report it to Mozilla with a reduced TC.

Changed 7 years ago by Garry Yao

Attachment: 5781.patch added

comment:2 Changed 7 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

I'm sure we've faced something similar in the past.

You're right, #3864 precisely.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

the idea is goo. But, after patch, the editor is automatically adding an empty line to the contents when loading it blank:

  1. Open the ajax sample.
  2. Create an editor instance.
  3. Click inside the editor.

In the source view, you'll see some unwanted stuff.

This is probably related to the improper creation for the bogus node, which doesn't match the CKEDITOR.dom.element.appendBogus code.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5781_2.patch added

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Confirmed removed
Owner: changed from Garry Yao to Sa'ar Zac Elias
Status: review_failedreview

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5749].

comment:7 Changed 5 years ago by Garry Yao

Cc: damo,joekdamo, joek

Fix is reverted with [5749] since Gecko has fixed the bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy