Opened 7 years ago

Closed 7 years ago

#5845 closed Bug (fixed)

Changing Number/Bullet List Style looses Cursor Positioning

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.3
Keywords: IBM Confirmed Firefox Review+ Cc: Damian, joek

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. Click on Insert/Remove Numbered List icon to start a Numbered list
  1. Right click next to the Number and select Numbered List Properties in the Context menu.
  1. Select Numbered List Type as Upper Roman in the Numbered List properties dialog and Click OK button.

Expected Result:

Cursor stays next to the new Roman Number inserted and when we start typing the text the new text appears as first list item.

Actual Result:

we could not see where the cursor is and when we start typing the text the new text replaces the new Roam Number that was inserted. If you are in the Starting line of a Nested numbered list,and when we start typing the text, the new text replaces the new roman number inserted and the new text concatenates with the text in the last list item at the previous level

Same behaviour happens with Bullets

Attachments (1)

5845.patch (1.4 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Garry Yao

Keywords: Confirmed Firefox added

Not a matter of the list style plugin, could be reproduced with all context menu commands, e.g. Paste. The problem is that only Firefox is selecting the entire list on right click when the list is empty.

Changed 7 years ago by Garry Yao

Attachment: 5845.patch added

comment:2 Changed 7 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:4 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5642].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy