Opened 7 years ago

Closed 7 years ago

#5894 closed Bug (fixed)

Buttons at bottom of dialogs don't expand to include their contents

Reported by: Alfonso Martínez de Lizarrondo Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.3
Component: UI : Dialogs Version: 3.3.1
Keywords: Cc: Hallvord R. M. Steen (Opera Software)

Description

If a new button is added to a dialog (or the translation of OK or Cancel is long enough), the label of the button won't be shown properly as it's being restricted to 60px wide.

The sample can be used to test the behavior and the patch fixes the problem.

Attachments (7)

buttons.html (5.0 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Sample file
5894.patch (1.5 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Proposed patch
5894_2.patch (1.5 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Updated patch
5894_2.png (10.7 KB) - added by Garry Yao 7 years ago.
krst_20101116-02.png (8.9 KB) - added by Krzysztof Studnik 7 years ago.
Under opera, buttons are partially moved outside dialog window
krst_20101116-01.png (10.0 KB) - added by Krzysztof Studnik 7 years ago.
Background in "Kama" skin Under Chrome 7.0.517 and IE, is not covering all width of dialog box
5894_3.patch (3.1 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (20)

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: buttons.html added

Sample file

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: 5894.patch added

Proposed patch

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

It's noticeable an issue with IE8+Compatibility. The Ok and Cancel buttons overlap with the test file.

I'm delaying it a bit as it involves too many tests. It would be better to have it committed at the beginning of the release development, instead of at the very end of it.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.5

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4.1CKEditor 3.5

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: 5894_2.patch added

Updated patch

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Status: review_failedreview

I've just updated the patch to the current trunk, and I've tested to work in standards and quirks mode with ie6, i7, i8, ie8 compat, ie9, ie9 compat.

Changed 7 years ago by Garry Yao

Attachment: 5894_2.png added

comment:5 Changed 7 years ago by Garry Yao

Milestone: CKEditor 3.5CKEditor 3.4.3
Status: reviewreview_failed

Buttons are not of the same width in IE7.

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

I've tested again with IE7, IE8, IE8 in compatibility, all in Standards and Quirks mode and it's working correctly for me in all of them

Any hint about how to reproduce the problem?

Changed 7 years ago by Krzysztof Studnik

Attachment: krst_20101116-02.png added

Under opera, buttons are partially moved outside dialog window

Changed 7 years ago by Krzysztof Studnik

Attachment: krst_20101116-01.png added

Background in "Kama" skin Under Chrome 7.0.517 and IE, is not covering all width of dialog box

comment:7 in reply to:  5 Changed 7 years ago by Krzysztof Studnik

Replying to garry.yao:

Buttons are not of the same width in IE7.

I can reproduce This behaviour IE7 (IE8 with dev tools IE7 mode enabled),it also happens under Opera 10.63. Under IE8 and Firefox, "Kama" skin, dialog box looks like on second screenshot.

comment:8 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Created https://bugs.opera.com/browse/DSK-319184 for the Opera problem, testcase available at http://martinezdelizarrondo.com/bugs/buttons.html

The background problem is not related to this ticket, it's a problem with the dialog that doesn't expand correctly, but to fix it the sample page just needs to define a better min-width for the dialog, for example 350.

I still can't reproduce the problem in the screenshot by Garry.

comment:9 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Cc: Hallvord R. M. Steen (Opera Software) added

The latest snapshot of Opera 11 fixes the problem in Opera: http://my.opera.com/desktopteam/blog/2010/11/17/new-and-improved

I don't know what's the proper way to address the issue in Opera. It might not be easy to find a good workaround to fix the current versions, for example a simple one is to leave the "width:60px" in a rule just for Opera, but that means that future versions will remain also broken although they can behave correctly.

On the other hand, if we don't do anything specific, when people gets the new CKEditor hopefully they might be using Opera 11 beta or maybe even the final version, so they'll see everything correct. It's a timing issue unless we must be sure that all works correctly with Opera 10.x. The drawback is that with this patch all the dialogs look worse in Opera 10.x

comment:10 Changed 7 years ago by Garry Yao

The problem is that Opera is not the single I got this overflow (pending to get confirmed from some other), as it's probably due to the table layout been used there, I guess it could be removed somehow, with it mainly used for alignment control in dialog body, leaving it in footer just for buttons doesn't make sense.

Changed 7 years ago by Garry Yao

Attachment: 5894_3.patch added

comment:11 Changed 7 years ago by Garry Yao

Owner: changed from Alfonso Martínez de Lizarrondo to Garry Yao
Status: review_failedreview

New patch try to resolve the problem from another angle, changes to the theme are to make the dialog content auto expand according to wider footer width.

comment:12 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_passed

comment:13 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6139].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy