Opened 9 years ago

Closed 9 years ago

#5928 closed Bug (invalid)

Problems with CKEDITOR_BASEPATH and Domino install

Reported by: oiha Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.1
Keywords: Pending Cc:

Description

I have read through the forum and ticket history and see there has been a few incidents with CKEDITOR_BASEPATH, but none that address ny problem specifically.

I have tried to install CKEDITOR in a Domino-environment for some time with no luck, even with this global variable set. FCKEditor works fine, and obviously I would like to install several versions side by side when testing. So far I've got an error on some "l.lang.something" missing, and the reason is that CKEDITOR_BASEPATH is truncated(?). When I put all the files in root it works, but that is messy. CKEDITOR_BASEPATH is set to "/path/db.nsf/ckeditor331/", but the path used is only "/path/db.nsf/".

Attachments (3)

editor.GIF (56.1 KB) - added by oiha 9 years ago.
Header part of problematic page
editor_2.GIF (25.4 KB) - added by oiha 9 years ago.
Extract from IE Developer Tools
editor_3.GIF (57.5 KB) - added by oiha 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added

Can you provide the steps to reproduce the problem or a URL to check it?

Changed 9 years ago by oiha

Attachment: editor.GIF added

Header part of problematic page

comment:2 Changed 9 years ago by oiha

I have included the header part of my last experiment. I have placed a few alerts in the onLoad event: loadEditor;alert(window.CKEDITOR_BASEPATH);alert(CKEDITOR.basePath).

The alerts tell me that I can set the basepath and that the internal variable is updated as expected. In this example I am pointing to a non-existing Domino database with a non-existing folder inside. The editor ignores my setting, even when I reset session and remove cache. It still works.

In the first place I uploaded the editor to /common/svg03547.nsf/ckeditor331/ folder. This reflected the ckeditor-folder in the download, as I skip one level. IE8 debugger showed me that the load failed on ../ckeditor331/lang/en.js which where searched for as ../lang/en.js in stead. So properly setting the basepath did not work.

In the second place I removed the ckeditor331 part of the path in all files, i.e. bumped them up one level. Then it worked without problems, but I lost version control.

In this last attempt I am trying to fool the editor without expected result. It kind of knows where they are and woun't give in to my command.

The CKEDITOR_GETURL is working and makes sure the URLs work for a Domino database.

comment:3 Changed 9 years ago by Alfonso Martínez de Lizarrondo

If you just place all the content under /common/svg03547.nsf/ckeditor331/ and use the /common/svg03547.nsf/ckeditor331/ckeditor.js file as the include then you won't even need to define the CKEDITOR_BASEPATH.

Changed 9 years ago by oiha

Attachment: editor_2.GIF added

Extract from IE Developer Tools

Changed 9 years ago by oiha

Attachment: editor_3.GIF added

comment:4 Changed 9 years ago by oiha

OK. I was afraid you would say that, because that is exactly were I started. :)

I have reverted to the suggested setup and run another test (see last 2 attachments). The three last entries in the header part are created by the editor itself and are as you can see relative URLs, which was not expected.

Checking the l-structure I find that the l.lang item is not populated. Checking l.config reveals that contentsCss has the proper value (absolute URL).

This problem was not there for FCKEditor v2.6.5, which was safely uploaded to fckeditor265/

I believe I follow your instructions in the documentation to the letter, so I am at miss at what's wrong.

comment:5 Changed 9 years ago by oiha

Does the basePath appear anywhere in the l-structure?

comment:6 Changed 9 years ago by oiha

I forgot: alert on CKEDITOR.basePath show http://<server>/common/svg03547.nsf/ this time

comment:7 Changed 9 years ago by oiha

Resolution: invalid
Status: newclosed

What can I say: Sorry for the inconvenience.

It turns out that the CKEDITOR_GETURL was not expanding URLs, so when I copied the code from CKEDITOR.getUrl it worked.

Looking forward to upgrade from FCKEDITOR 2.6.5!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy