Opened 9 years ago

Closed 9 years ago

#5945 closed Bug (worksforme)

FF - issues with keyboard Navigation when we insert a page break in the editor

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.3
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. Insert some text, Click on Insert Page break icon and enter some text after the Page break.
  1. Now try to use UP Arrow key to go to Paragraph above the Page break

Expected Result:

we should be able to go to the paragraph above Page break using UP Arrow keys.

Actual Result:

when we press UP Arrow key for the first time it is creating an Empty Paragraph below the Page break & keep pressing the UP Arrow key slowly. No matter how many number of times you press it cursor won't go to Paragraph above Page break. when we press UP Arrow key fastly it will move after few tries.

And also when we Position the cursor in the Empty Paragraph after Page break & try to delete it will not work.

Change History (3)

comment:1 Changed 9 years ago by Tobiasz Cudnik

Could you please check if patch from #5079 fixes your issue ? It changes pagebreak to inline element, like anchors. Then LEFT (or right in RTL) arrow would always work to go back.

comment:2 Changed 9 years ago by Charlie

I tested this on FF 3.6.6 quick and seems to be working using that patch. The issue should be resolved.

comment:3 Changed 9 years ago by Tobiasz Cudnik

Resolution: worksforme
Status: newclosed

As #5079 is now fixed in the trunk, i'm closing this one as WorksForMe.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy