Opened 10 years ago

Closed 10 years ago

#6023 closed Bug (fixed)

[[Opera]] Can not delete number/bullet list by pressing Backspace key

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: IBM Opera Cc: Damian, joek, Hallvord R. M. Steen (Opera Software)

Description

To reproduce the defect:

  1. Open Ajax sample & enter some text,then click number list or bullets list icon
  1. Press Backspace key to delete all content

Exected result:

  1. After step1, entered text display with number/bullet list
  2. Can delete all content by pressing Backspace key.

Actual result:

  1. Pressing Backspace key can delete all text, but can not delete number or bullet list.

Attachments (2)

krst 11.40.05 .avi (38.5 KB) - added by Krzysztof Studnik 10 years ago.
Confirmed in Opera 10.61.3484
6023.patch (2.1 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 10 years ago by Sa'ar Zac Elias

Status: newconfirmed

comment:2 Changed 10 years ago by Sa'ar Zac Elias

Keywords: Opera added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

This is a browser bug. We should report it to Opera, but due to other bugs in the browser it's not easy to come with a reduced TC for them.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Cc: Hallvord R. M. Steen (Opera Software) added

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

For reference, this is the Opera bug that makes a simple TC hard to have:
https://bugs.opera.com/browse/CORE-31549

comment:6 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

I can not reproduce this problem with http://ckeditor.com/demo and an upcoming 10.70 desktop build of Opera. What Opera version was used for testing?

comment:7 in reply to:  6 Changed 10 years ago by Satya Minnekanti

Replying to hallvord@…:

I can not reproduce this problem with http://ckeditor.com/demo and an upcoming 10.70 desktop build of Opera. What Opera version was used for testing?

we were using Opera 10.6

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

I can confirm the issue with Opera 10.60 build 3445.

comment:9 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

This is now tracked internally as CORE-31942 Seems it only causes problems if there is no content before the list.

I suggest you close this bug and do not try to work around it, awaiting the pending fix from Opera's side.

comment:10 in reply to:  9 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

Replying to hallvord@…:

This is now tracked internally as CORE-31942

(and if it's not clear from the context, by "internally" I meant @Opera)

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Thanks for the details hallvord.

We'll keep the ticket open until we're able to confirm the fix in an Opera build. No fix will be provided at our side.

Changed 10 years ago by Krzysztof Studnik

Attachment: krst 11.40.05 .avi added

Confirmed in Opera 10.61.3484

comment:12 Changed 10 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

comment:13 Changed 10 years ago by Paweł Horzela

We will be waiting for an Opera release that has the issue fixed to close the ticket.

comment:14 Changed 10 years ago by Garry Yao

Owner: Paweł Horzela deleted
Status: assignednew

comment:15 Changed 10 years ago by Damian

Is there any update on this issue either from CKSource or Opera?

Changed 10 years ago by Garry Yao

Attachment: 6023.patch added

comment:16 in reply to:  15 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newreview

The bug affects all empty list item, not specific to the start of document position.

Replying to damo:

Is there any update on this issue either from CKSource or Opera?

We'd like to propose a internal fix before Opera's fix lands.

comment:17 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

On Opera's side, the internal bug was fixed last December, so the fix is on its way out - should be working now in 11.10 builds from http://my.opera.com/desktopteam/

comment:18 Changed 10 years ago by Wiktor Walc

I've just checked it and it looks like the bug is fixed in Opera 11.10.

@satya could you confirm it on your side?

comment:19 in reply to:  18 Changed 10 years ago by Satya Minnekanti

Replying to wwalc:

I've just checked it and it looks like the bug is fixed in Opera 11.10.

@satya could you confirm it on your side?

@wwalc This was fixed in Opera 11.10

comment:20 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: reviewclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy