Opened 7 years ago

Closed 7 years ago

#6027 closed Bug (fixed)

[[FF]] Modifying Table Properties by selecting more than one cell, causing several issues

Reported by: Satya Minnekanti Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.1
Component: General Version: 3.3
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect:

  1. open Ajax sample.
  1. Insert a Table with 5 rows & 6 columns.
  1. Select more than one cell( for ex: Top 2 cells) and click on Table Properties option.
  1. Try to modify any of Table Properties and Click OK button.

Expected Result:

Table properties should be modified successfully.

Actual Result:

we are getting the following error in firebug when we press OK button

k.$ is undefined [Break on this error] h.get=function(i){return i&&(i.$?i:new...turn c?i.replace(/<\?[>]*>/g,):i;

and also when we press cancel and close the dialog, the last Table cell that was selected gets deleted.

And also it is giving the option to edit the No of Rows & Columns for the user which it should not be.

Attachments (2)

6027.patch (665 bytes) - added by Sa'ar Zac Elias 7 years ago.
6027_2.patch (742 bytes) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Sa'ar Zac Elias

Status: newconfirmed

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5

comment:3 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6027.patch added

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Status: assignedreview

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

The fix is correct, but now that "if" block results redundant, because selectedTable will already be null (or undefined) if getAscendant doesn't find the table. The code should get simplified.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6027_2.patch added

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Status: review_failedreview

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:8 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5820].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy