Opened 5 years ago

Closed 3 years ago

Last modified 18 months ago

#6086 closed Bug (fixed)

Pasting mixed BiDi content from Word removes spacings

Reported by: TheNez Owned by: garry.yao
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.3.1
Keywords: Cc:

Description

While trying to use mixed Hebrew-English text, as can be seen in image "01.bmp" I am getting the output seen in image "02.bmp"

You can see that in the vicinity of mixed language (where there are no punctuation marks) a separation (space) is missing.

I must say that in the previous version, this problem did not exist, still I would like to use this one due to its excellent improvements.

Attachments (4)

01.bmp (196.5 KB) - added by TheNez 5 years ago.
02.jpg (58.4 KB) - added by TheNez 5 years ago.
test.doc (21.5 KB) - added by TheNez 5 years ago.
a word file containing bidi texts. just copy it and paste in the text editor to find that the bidi text is without spaces
6086.patch (809 bytes) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (22)

Changed 5 years ago by TheNez

Changed 5 years ago by TheNez

comment:1 Changed 5 years ago by Saare

  • Resolution set to invalid
  • Status changed from new to closed

I don't see any problem writing Hebrew and English mixed together. Also, the browser is responsible for the text rendering. Feel free to open the ticket for any new discoveries.

comment:2 Changed 5 years ago by TheNez

There is no problem in writing hebrew and english in a single sentence. The problem is in pasting from word mix words in sentence. You can check the HTML source to see that in the HTML a space charecter is missing between the english and hebrew words, as can be seen in the images attached.

comment:3 Changed 5 years ago by Saare

  • Resolution invalid deleted
  • Status changed from closed to reopened

I can confirm the bug when pasting from Word.

comment:4 Changed 5 years ago by Saare

  • Status changed from reopened to confirmed

comment:5 Changed 5 years ago by Saare

  • Summary changed from Problem integrating mixed hebrew-english text within CKEditor to Pasting mixed BiDi content from Word removes spacings

comment:6 Changed 5 years ago by tobiasz.cudnik

  • Milestone set to CKEditor 3.4.2
  • Status changed from confirmed to new

comment:7 Changed 5 years ago by Saare

  • Status changed from new to confirmed

comment:8 Changed 5 years ago by paho

  • Owner set to paho
  • Status changed from confirmed to assigned

comment:9 Changed 5 years ago by garry.yao

  • Milestone CKEditor 3.4.2 deleted
  • Status changed from assigned to pending

Could you provide the .doc that used to reproduce this bug? Or it's just because of the pasting?

Changed 5 years ago by TheNez

a word file containing bidi texts. just copy it and paste in the text editor to find that the bidi text is without spaces

comment:10 Changed 5 years ago by TheNez

i've added a text file with bidi text. after copying and pasting you will find that the english and hebrew words are without any spacing.

comment:11 Changed 5 years ago by paho

  • Status changed from pending to confirmed

I can reproduce this bug using the .doc from attachment.

Changed 5 years ago by garry.yao

comment:12 Changed 5 years ago by garry.yao

  • Milestone set to CKEditor 3.1
  • Owner changed from paho to garry.yao
  • Status changed from confirmed to review

Now I can confirm the bug, comes from the word cleanup processing logics.

comment:13 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.6

comment:14 Changed 4 years ago by Saare

Works for me on trunk, can you confirm?

comment:15 Changed 4 years ago by Saare

  • Status changed from review to pending

comment:16 Changed 4 years ago by wwalc

  • Milestone CKEditor 3.6 deleted

Looks like a duplicate of #6751, it started working correctly exactly in rev. [6557].

@TheNez - could you confirm, that the issue is gone in 3.5.3?

comment:17 Changed 3 years ago by j.swiderski

  • Resolution set to fixed
  • Status changed from pending to closed

Issue is gone. I have checked it under latest CKEditor 3.6.2

comment:18 Changed 18 months ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy