Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6087 closed Bug (fixed)

IE: Caret doesn't blink on RTL dialogs

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: UI : Dialogs Version: 3.0
Keywords: IE Opera IBM Cc: Satya Minnekanti

Description

In IE, the caret is not visible inside dialogs when the UI is RTL.

This is a followup ticket for comment:19:ticket:4615.

Attachments (5)

6087.patch (2.2 KB) - added by Tobiasz Cudnik 10 years ago.
6087_2.patch (2.3 KB) - added by Tobiasz Cudnik 10 years ago.
6087_3.patch (3.5 KB) - added by Garry Yao 10 years ago.
6087.PNG (14.9 KB) - added by Sa'ar Zac Elias 10 years ago.
6087_4.patch (4.4 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (33)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Status: newconfirmed

I'm constantly able to reproduce it with IE8 (Win7 64).

Saar instead doesn't see any problem with the Hebrew IE8 and IE7 (XP and Vista 32).

comment:2 Changed 10 years ago by Sa'ar Zac Elias

It works fine for me with IE6 @ XP 32.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Cc: Satya Minnekanti added
Keywords: IBM added

#6176 has been marked as DUP.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4.1

comment:5 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: confirmedassigned

Changed 10 years ago by Tobiasz Cudnik

Attachment: 6087.patch added

comment:6 Changed 10 years ago by Tobiasz Cudnik

Status: assignedreview

comment:7 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

I can live with the small extra padding at the right side but unfortunately this patch ruins the border at the left side for me.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 6087_2.patch added

comment:8 Changed 10 years ago by Tobiasz Cudnik

Status: review_failedreview

comment:9 Changed 10 years ago by Sa'ar Zac Elias

Looks great at my side, let's also wait to Fred to see it really solved the problem.

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

:/ this patch makes no difference for me. It would be wonderful to have someone else confirming the exact effect I'm having.

comment:11 Changed 10 years ago by Garry Yao

Patch WFM in IE8 but not IE7.

comment:12 Changed 10 years ago by Garry Yao

Keywords: Opera added

Opera is affected also.

comment:13 Changed 10 years ago by Garry Yao

Owner: changed from Tobiasz Cudnik to Garry Yao
Status: review_failedassigned

Changed 10 years ago by Garry Yao

Attachment: 6087_3.patch added

comment:14 Changed 10 years ago by Garry Yao

Status: assignedreview
Version: 3.0

comment:15 Changed 10 years ago by Paweł Horzela

In my case (Win7 64) patch works for FF, Opera, Chrome and IE8. For IE7 right border of some textboxes is missing.

comment:16 Changed 10 years ago by Sa'ar Zac Elias

Looks ok on my env and IE8. Also need others to test the patch to see it's actually resolved for everybody.

comment:17 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:18 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [5975].

comment:19 Changed 10 years ago by James

I believe that this fix may have introduced a new bug in IE7.

Select Arabic or Hebrew from the languages sample in IE7.
Click into the editor and click on the Insert Table icon.
See that the dialog appears BUT notice that the Summary & Caption text fields are missing a right hand edge.

Should a new ticket be raised to highlight this defect or should this ticket be reopened?

comment:20 Changed 10 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: closedreopened

Confirmed with IE8 compat and IE7 mode, OK with standart and quirks.. \:
Reverted [5975] with [5998].

Changed 10 years ago by Sa'ar Zac Elias

Attachment: 6087.PNG added

Changed 10 years ago by Garry Yao

Attachment: 6087_4.patch added

comment:21 Changed 10 years ago by Garry Yao

Status: reopenedreview

The new bug only happens on fields that has a relative 100% width in layout boxes, new patch gives layout boxes also a small padding to conquer that.

comment:22 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:23 Changed 10 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5999].

comment:24 Changed 10 years ago by Dinu

Reopen: Now the cursor disappears in LTR, in IE7, IE8 at right side.

comment:25 Changed 10 years ago by Sa'ar Zac Elias

I'm not able to reproduce your problem @dinu.

comment:26 Changed 10 years ago by Dinu

  • Open nightly build demo (any instance, English)
  • Click image button
  • In URL field type a very long string
  • Caret will disappear in the right side as the text is wider than the input
  • Same happens with nearly all dialog text input fields

comment:27 Changed 10 years ago by Sa'ar Zac Elias

Ok I can see that now, it has nothing to do with that ticket though as I was able to reproduce the bug also on the demo. You can file a new ticket for that bug.

comment:28 Changed 10 years ago by Dinu

Ok, I thought it was related because it involves the same caret-at-right position. I'll file a new bug then.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy