Opened 10 years ago

Closed 10 years ago

#6117 closed Bug (fixed)

BIDI: Language direction is changing when we come out of Numbered/Bulleted list

Reported by: Satya Minnekanti Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.4.1
Component: General Version: 3.4 Beta
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect:

Scenario 1:

  1. Open Ajax sample.
  1. Type few lines of text, select all the lines & click on RTL icon in the Tool bar.
  1. See that the language direction of the lines are changed to Right and RTL Icon in the Tool bar is selected.
  1. Now select all the lines and click on Numbers/Bullets icon in the Tool bar.
  1. See that a Numbered/Bulleted list appears with RTL language direction.
  1. Now select all the list items and press Decrease Indent icon.

Expected Result:

Numbered/Bulleted list is removed but the Language direction of text in the lines should still be from Right to Left(RTL).

Actual Result:

Numbered/Bulleted list is removed but Language direction of text in in the lines is removed and they have no language direction set.

Scenario 2:

  1. Open Ajax sample.
  1. Type few lines of text, select all the lines & click on RTL icon in the Tool bar.
  1. See that the language direction of the lines are changed to Right and RTL Icon in the Tool bar is selected.
  1. Now select all the lines and click on Numbers/Bullets icon in the Tool bar.
  1. See that a Numbered/Bulleted list appears with RTL language direction.
  1. go to the last list item and press Enter Twice.

Expected Result:

See that you are out of Numbered/Bulleted but the direction of text in the New Paragraph should still be from Right to Left(RTL).

Actual Result:

we are out of Numbered/Bulleted list is removed but New Paragraph has no explicit Language direction set.

Attachments (2)

6117.patch (747 bytes) - added by Tobiasz Cudnik 10 years ago.
6117_2.patch (817 bytes) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Milestone: CKEditor 3.4.1
Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Tobiasz Cudnik

Attachment: 6117.patch added

comment:2 Changed 10 years ago by Tobiasz Cudnik

Status: assignedreview

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

The fix looks like correct, but I'm not able to test it due to #6138. We need to fix that one first.

comment:4 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

The direction CSS should also be considered.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 6117_2.patch added

comment:5 Changed 10 years ago by Tobiasz Cudnik

Status: review_failedreview

comment:6 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:7 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: review_passedclosed

Fixed with [5857].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy