Opened 9 years ago

Closed 8 years ago

#6221 closed Bug (worksforme)

removePlugins setting still loads image plugin

Reported by: AndiU Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Cc:

Description (last modified by Krzysztof Studnik)

When you remove a plugin by using the removePlugins setting it will not affect the image plugin. Even when you do the following, it will still open the image dialog by doublecklicking on an image:

$settings['removePlugins'] = 'scayt,menubutton,contextmenu,image,forms';

So it seems the image plugin is still loaded by ckeditor.

The only way to effectively remove the image plugin and prevent loading is to exclude it from the plugin list:

$settings['plugins'] = 'a11yhelp,basicstyles,blockquote,button,clipboard,colorbutton,colordialog,contextmenu,div,elementspath,enterkey,entities,find,font,format,horizontalrule,htmldataprocessor,indent,justify,keystrokes,list,liststyle,maximize,newpage,pagebreak,pastefromword,pastetext,popup,preview,removeformat,resize,save,showblocks,showborders,sourcearea,stylescombo,table,tabletools,specialchar,tab,toolbar,undo,wysiwygarea,wsc';

Change History (4)

comment:1 Changed 9 years ago by Krzysztof Studnik

Component: GeneralUI : Dialogs
Description: modified (diff)
Keywords: Image Plugin added

comment:2 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Image Plugin removed
Status: newpending

I can't reproduce this problem.

Are you sure that you have cleared your cache?

comment:3 Changed 8 years ago by Lewis

I experienced this issue also.

The following line:

$CKEditor->configremovePlugins?='elementspath,resize,filebrowser,flash,image';

Did not remove the image plugin

But using:

$CKEditor->configplugins? = 'all plugins bar the above';

did.

I also found that my own implementation of the image plugin (which replaced the URL text with a drop down of URLs pulled from a database) failed to show in the context menu with the later set, but it 'Image Properties' showed twice in the context menu with the image plugin loaded, but both links point to the original image plugin. Only used PHP to initiate the editor, but this may be an issue in the PHP load rather than CK itself.

comment:4 Changed 8 years ago by Wiktor Walc

Resolution: worksforme
Status: pendingclosed

@ewis42 - the forms plugin requires image plugin, so you need to remove it as well in order to turn the image plugin off:

config.removePlugins = 'forms,image';

WFM as well in CKEditor 3.6.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy