Opened 9 years ago

Closed 8 years ago

#6222 closed Bug (duplicate)

Cut/Copy/Paste menu disabled after text is cut from WYSIWYG editor

Reported by: Krzysztof Studnik Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.4.1
Keywords: IE Cc: satya_minnekanti@…

Description (last modified by Krzysztof Studnik)

Steps as in attached video Open CK in IE
Select all text and right click on selection, from menu select "cut",
On empty space right click, select paste. Text is pasted

Retry above operations. Second time, options in menu are disabled, the cursor jumps to upper left corner.

When View source is selected, part of paragraf is left in the editor:

<p>
	<span style="display: none">&nbsp;</span></p>

Attachments (1)

krst 09.10.03 .avi (254.0 KB) - added by Krzysztof Studnik 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Krzysztof Studnik

Attachment: krst 09.10.03 .avi added

comment:1 Changed 9 years ago by Krzysztof Studnik

Connected to #6220

comment:2 Changed 9 years ago by Krzysztof Studnik

Description: modified (diff)

comment:3 Changed 9 years ago by Tobiasz Cudnik

Keywords: cut paste contextmenu IE removed
Status: newconfirmed

comment:4 Changed 9 years ago by Tobiasz Cudnik

Keywords: IE added

comment:5 Changed 9 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:6 Changed 9 years ago by Garry Yao

Reproduced in IE8, in IE7 now it's even not possible to paste.

comment:7 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I latest CKEditor 3.6.2 the span tag does no longer occur.

As for disabled context menu, this is a duplicate of #5538.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy