Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6249 closed Bug (fixed)

BIDI: bullets in a Numbered/Bulleted List getting clipped when going from LTR to RTL

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.1
Component: Core : BiDi Version: 3.4
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect

  1. Open Ajax sample.
  1. Create a 2 level Numbered/Bulleted list as shown in the attachment.
  1. Keep the cursor in the list item one on first level.
  1. Click on RTL Icon.

Result: The first number/bullet is missing from the list.

Note: Firefox tackles this by adding a horizontal scrollbar.

Attachments (3)

Numbered list.jpg (45.4 KB) - added by Satya Minnekanti 7 years ago.
6249.patch (643 bytes) - added by Paweł Horzela 7 years ago.
Patch
6249_2.patch (400 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (17)

Changed 7 years ago by Satya Minnekanti

Attachment: Numbered list.jpg added

comment:1 Changed 7 years ago by Tobiasz Cudnik

Status: newconfirmed

Alternative TC:

  • Use following content
    <ul>
    	<li dir="rtl">
    		foo
    		<ul>
    			<li>
    				bar</li>
    		</ul>
    	</li>
    </ul>
    
  • First list-dot will be pushed out of the view port to the right.

comment:2 Changed 7 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

Changed 7 years ago by Paweł Horzela

Attachment: 6249.patch added

Patch

comment:3 Changed 7 years ago by Paweł Horzela

Status: assignedreview

Changed 7 years ago by Garry Yao

Attachment: 6249_2.patch added

comment:4 Changed 7 years ago by Garry Yao

Status: reviewreview_failed

This's more a browser CSS bug, where list padding is not adjusted in according to text direction and even worse there's no CSS rule that could really compensate it, the attached patch is a workaround.

comment:5 Changed 7 years ago by Paweł Horzela

Status: review_failedreview

comment:6 Changed 7 years ago by Garry Yao

Component: GeneralCore : Lists
Milestone: CKEditor 3.5.1
Version: 3.4

comment:7 Changed 7 years ago by Garry Yao

Component: Core : ListsCore : BiDi

The related #6634 will be handled at this ticket also.

comment:8 Changed 7 years ago by Garry Yao

Summary: BIDI: IE First number/bullet in a Numbered/Bulleted List getting clipped when going from LTR to RTLBIDI: bullets in a Numbered/Bulleted List getting clipped when going from LTR to RTL

comment:9 Changed 7 years ago by Garry Yao

Owner: changed from Paweł Horzela to Garry Yao
Status: reviewassigned

comment:10 Changed 7 years ago by Garry Yao

Status: assignedreview

comment:11 Changed 7 years ago by Krzysztof Studnik

#6692 & #6891 are Related

comment:12 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_passed

Looks like this simple fix is enough.

comment:13 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6274].

comment:14 Changed 7 years ago by Satya Minnekanti

http://dev.ckeditor.com/6891 which is marked as a duplicate of this defect is not fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy