Opened 9 years ago

Closed 9 years ago

#6254 closed Bug (worksforme)

BIDI: creating a Numbered/Bulleted list causing improper behavior on bidi

Reported by: Satya Minnekanti Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.4
Keywords: IBM Cc: Damian, joek

Description (last modified by Krzysztof Studnik)

To reproduce the defect

  1. Open Language sample and select Language as Hebrew or Arabic.
  2. Input data on 1st line and press Enter.
  3. Click on LTR & Align Right icons, input data on 2nd line & press Enter.
  4. Click on RTL icon, input data on 3nd line.
  5. Select all text and press "Numbered list" button.

Error:

All of the text language direction became LTR with Numbered, & 1st ,3rd became left aligned on bidi base env.

Other case: while all text became LTR, first line si alligned to left, 2nd and 3rd to right, numbers on the left

Expected result:

1st line data is keeping "RTL" with number1 on the right,

2nd line data is keeping "LTR", "Align-Right" with number2 on the left.

The 3st line data is keeping "RTL" with number3 on the right,

Attachments (2)

krst_13.13.25.png (18.1 KB) - added by Krzysztof Studnik 9 years ago.
Confirmed on Trunk
krst 14.05.09 .avi (200.0 KB) - added by Krzysztof Studnik 9 years ago.
Behavior in IE8

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by Sa'ar Zac Elias

Status: newpending

I'm not able to reproduce the bug. I'm assuming that the list creation should be a step before the 2nd step, correct me if I'm wrong.

Changed 9 years ago by Krzysztof Studnik

Attachment: krst_13.13.25.png added

Confirmed on Trunk

Changed 9 years ago by Krzysztof Studnik

Attachment: krst 14.05.09 .avi added

Behavior in IE8

comment:2 Changed 9 years ago by Krzysztof Studnik

Description: modified (diff)
Status: pendingconfirmed
Version: 3.43.4.1 (SVN - trunk)

I think attached video shows what we need to proove?

comment:3 Changed 9 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.4.1
Version: 3.4.1 (SVN - trunk)3.4

comment:4 Changed 9 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: confirmedassigned

comment:5 Changed 9 years ago by Tobiasz Cudnik

Fixable by 6253.patch from #6253.

comment:6 Changed 9 years ago by Tobiasz Cudnik

Resolution: worksforme
Status: assignedclosed

WFM as of [5968].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy