Opened 9 years ago

Closed 9 years ago

#6314 closed Bug (duplicate)

Checkbox Properties not available in the context menu

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4
Keywords: Safari Mac Cc:

Description

After creating the checkbox element, the "Checkbox Properties" item is available, but after switching to source mode and back I do not see it anymore.

To reproduce:

  • create the form element
  • create the checkbox element inside of it
  • switch to source mode
  • switch to wysiwyg mode
  • right click on that checkbox
  • result: "Checkbox Properties" is not available

another way to reproduce it, paste the following in source mode and switch to wysiwyg mode:

<form action="fdfgdfg" method="get" name="dfgd">
	<input name="dfgdf" type="checkbox" value="dfgdfg" />&nbsp;</form>}}}

Just like in #6312, double clicking on that element works fine.

Confirmed in Safari 5.0.2 @ Snow Leopard. I did not check versions older than 3.4.

Change History (3)

comment:1 Changed 9 years ago by Wiktor Walc

Same problem with:

  • Radio Button
  • Text Area
  • Text Field

Other form elements are recognized properly.

comment:2 Changed 9 years ago by Matti Järvinen

Since it seems that certain form input elements keep bugging different browsers I would be happy with solution I posted as part in #4056 (form_changes.zip) which uses fake elements to replace checkboxes and radioboxes.

Allthough changes are dated and should be rewritten I see no harm done in this approach.

comment:3 Changed 9 years ago by Wiktor Walc

Resolution: duplicate
Status: newclosed

Duplicate of #5804.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy