Opened 10 years ago

Closed 10 years ago

#6332 closed Bug (fixed)

IE: V2 skin bottom dialog's border broken

Reported by: Tobiasz Cudnik Owned by: Paweł Horzela
Priority: Normal Milestone: CKEditor 3.4.2
Component: UI : Dialogs Version: 3.4
Keywords: IE Cc:

Description

V2 skin bottom dialog's border is broken in IE since version 3.4. It was fine in 3.4 Beta and 3.3.2.

Refer to attached screenshot. Reproduced on IE8 standards mode.

Attachments (4)

2010-09-21-123724_490x499_scrot.png (17.5 KB) - added by Tobiasz Cudnik 10 years ago.
6332.patch (427 bytes) - added by Paweł Horzela 10 years ago.
Patch
6332_2.patch (5.8 KB) - added by Paweł Horzela 10 years ago.
Patch
6332_3.patch (2.0 KB) - added by Paweł Horzela 10 years ago.
Patch

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by Tobiasz Cudnik

comment:1 Changed 10 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.4.2
Status: newconfirmed

comment:2 Changed 10 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

comment:3 Changed 10 years ago by Paweł Horzela

Regresion introduced in revision 5840: http://dev.ckeditor.com/changeset/5840

comment:4 Changed 10 years ago by Paweł Horzela

'change' event is not fired because of 'noChangeEvent' flag that is always set to 'true'.

comment:5 Changed 10 years ago by Paweł Horzela

Regression connected with ticket #6137: http://dev.ckeditor.com/ticket/6137

comment:6 Changed 10 years ago by Paweł Horzela

Because 'change' event is not fired, body.$.offsetHeight of dialog window is not recalculated and the vertical borders are too long. We must expand the content of the dialog window to be as long as borders.

Changed 10 years ago by Paweł Horzela

Attachment: 6332.patch added

Patch

comment:7 Changed 10 years ago by Paweł Horzela

Status: assignedreview

comment:8 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

I've seen similar things happen randomly also in office2003. A more generic solution could be found.

comment:9 Changed 10 years ago by Paweł Horzela

I reverted changes from revision [5840] and added new patch resolving ticket #6137 without dialog window css problem.

Changed 10 years ago by Paweł Horzela

Attachment: 6332_2.patch added

Patch

comment:10 Changed 10 years ago by Paweł Horzela

Status: review_failedreview

comment:11 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

We didn't take your proposed approach earlier because we concluded that it's more than just this specific field. We'll face the same problem everytime we use this event, i.e. when there is a default height set in this dialog.

Changed 10 years ago by Paweł Horzela

Attachment: 6332_3.patch added

Patch

comment:12 Changed 10 years ago by Paweł Horzela

Status: review_failedreview

comment:13 Changed 10 years ago by Garry Yao

Status: reviewreview_passed

comment:14 Changed 10 years ago by Paweł Horzela

Resolution: fixed
Status: review_passedclosed

Fixed with [5945]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy