Opened 7 years ago

Closed 7 years ago

#6361 closed Bug (invalid)

IE: Inline style not removed

Reported by: Tobiasz Cudnik Owned by: Paweł Horzela
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.3.2
Keywords: IE Cc:

Description (last modified by Tobiasz Cudnik)

Regression since 3.3.2 (worked on 3.3.1). Apply and try to remove bold on some non-collaped selection when in enterMode=BR, it will not be removed.

  1. Set config.enterMode = CKEDITOR.ENTER_BR
  2. Type some text
  3. Select some text
  4. Apply bold
  5. Apply bold again to remove this style

Expected: Text is not bold.

Present: Text is still bold.

Change History (4)

comment:1 Changed 7 years ago by Tobiasz Cudnik

Keywords: IE added
Status: newconfirmed

comment:2 Changed 7 years ago by Tobiasz Cudnik

Description: modified (diff)

comment:3 Changed 7 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

comment:4 Changed 7 years ago by Tobiasz Cudnik

Resolution: invalid
Status: assignedclosed

It turns out that this behavior was caused by custom selectionChange listener

editor.on('selectionChange', function()
{
  console.log('foo')
});

Without it, i can't reproduce this issue anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy