Opened 8 years ago

Closed 7 years ago

#6366 closed Bug (duplicate)

[Webkit] adds inline styles on drag and drop operation

Reported by: Karen Ananiev Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Webkit Cc:

Description

  • Edit contents.css
  • Add any CSS rule. For example, h1 { color:red }
  • Open editor and create H1 element with some text
  • Select the text of this header element and drag and drop it on other place
  • Switch to source mode


You'll get something like

<h1 style="color: red; ">
	header 1</h1>

Change History (5)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: Webkit added
Status: newconfirmed
Version: 3.0

I have used replacebycode sample (with two editors) to reproduce the issue.

Result of dragging header from one editor to another is as follows:

<div style="font-family: Arial, Verdana, sans-serif; font-size: 12px; color: rgb(34, 34, 34); background-color: rgb(255, 255, 255); ">
	<h1 style="color: red; ">
		text</h1>
</div>

Issue is reproducible on Webkit browsers from CKE 3.0

comment:2 Changed 8 years ago by Jakub Ś

#7146 is probably related to this one.

comment:3 Changed 8 years ago by Jakub Ś

#6121 was marked as duplicate

comment:4 Changed 8 years ago by Jakub Ś

@fredck comment from #6121:

WebKit is well known about changing dragged or pasted stuff. We're not able to fix it. All we can do is reporting it to them, so they can make things work properly at their side.

comment:5 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

Whether it's dragging or pasting the cause and result is the same.

I'm closing this issue as a DUP of #7146 as the later has more information.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy