Opened 12 years ago

Closed 7 years ago

#637 closed New Feature (fixed)

New optional way of handling Editor height?

Reported by: bngobngo@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc:

Description (last modified by Martin Kou)

As it is today the editor height refelects the editiors editable area and the toolbar area.

When you change the width of a given editor the total editor height (editable area + toolbar area) remains the same, but as the toolbar buttons wraps the editable area gets smaller.

If it is possible it would be nice to be able to control the editable editor area height. In this case I do not care about the toolbar area height.

If I set height=200px then I want the editable area to be at 200px no matter what.

Let say you have a CMS system and want the user to be able to edit the text and be able to se what it would look like the moment he writes it. Let say he is entering text that are to be visible in a narrow part of the site. Then it would be nice to dynamically resize the editor to that width (which is possible today) but without eventually messing up the editable area because the toolbar buttons wraps and makes the editable erea smaller.

Would be nice to be implemented as a parameter setting in the fckeditor.js file. e.g. like this:

FCKConfig.EditAreaFixed = true;

Keep up the good work.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1187867&group_id=75348&atid=543656

Change History (5)

comment:1 Changed 12 years ago by Martin Kou

Description: modified (diff)
Reporter: changed from Martin Kou to bngobngo@…

comment:2 Changed 12 years ago by pcool

I agree with this! Look at how Drupal has a nice way to resize their textareas or how tinyMCE does it

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:4 Changed 11 years ago by Andy

I agree. I've just installed fckeditor and it looks good but I'm surprised I can't change the height of the textarea.

comment:5 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Just have a look at:
http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.resize_maxHeight[[BR]] http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.resize_minHeight

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy