Opened 10 years ago

Closed 10 years ago

#6385 closed Bug (duplicate)

IE throws Javascript error when using anchor

Reported by: Flo Schuessel Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.1
Keywords: Cc:

Description

When you select text an try to set an anchor IEs come up with an error "Invalid argument".

Attachments (3)

IE6WinXP.png (148.0 KB) - added by Flo Schuessel 10 years ago.
IE7WinXP.png (145.9 KB) - added by Flo Schuessel 10 years ago.
IE8WinXP.png (217.4 KB) - added by Flo Schuessel 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Status: newpending

Cannot reproduce it, what version of IE are you using ? Is it reproducible on our demo page ?

comment:2 Changed 10 years ago by Flo Schuessel

I testet:

  • IE 6 Win XP (native, no IE Collection or sth.)
  • IE 7 Win XP (native, no IE Collection or sth.)
  • IE 8 Win XP (native, no IE Collection or sth.)

The test was also done on your demo page (full demo). Select some text, then press anchor, set some text and on the first click there is a javascript error. Second click sets the anchor then but without text. This is on IE6 and IE8 the case.

On IE7 the first anchor is set correctly (with the selected text remaining) but a setting a second anchor fails as described above.

I'll attach screens of each browser.

Changed 10 years ago by Flo Schuessel

Attachment: IE6WinXP.png added

Changed 10 years ago by Flo Schuessel

Attachment: IE7WinXP.png added

Changed 10 years ago by Flo Schuessel

Attachment: IE8WinXP.png added

comment:3 Changed 10 years ago by Tobiasz Cudnik

Status: pendingconfirmed

Although i can't reproduce this on any of my local working copies, i DO can reproduce it on demo page.

Problem seems to be caused by /core/dom/range.js L71:

startNode.split( startOffset );

and to be exact, /core/dom/text.js L93:

var retval = new CKEDITOR.dom.text( this.$.splitText( offset ), doc );

This looks quite familiar, do we already have a ticket for this part of code ?

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: confirmedclosed

I think that all the issues with anchors are addressed with the patch in #3582. Marking as dup.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy