Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#6408 closed Bug (fixed)

AutoGrow 24px too high on IE

Reported by: Dinu Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.4.2
Keywords: IE Cc:

Description

On IE 7,8 the autogrow computed size is 24px too high; I've tracked it down to
newHeight = doc.getBody().$.scrollHeight + 24;
I don't know what that adjustment is for; I'm assuming it's to compensate for an eventual horizontal scrollbar, in which case:

  • 24 is tentative, the scrollbars are not expected to have a certain size, so scrollbar height should be computed by other means
  • only add height if a hrz scrollbar is actually present
  • if additional height is added, schedule another resize to shrink editor back if scrollbars go away as result of the first resize; although it's counterintuitive (the horizontal scrollbar going away on a vertical resize, it's been known to happen)

I'll try to look some more at this and figure a way for myself

Attachments (3)

6408.patch (668 bytes) - added by Sa'ar Zac Elias 7 years ago.
24px.jpg (189.6 KB) - added by Dinu 7 years ago.
6408_2.patch (665 bytes) - added by Dinu 7 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by Sa'ar Zac Elias

Keywords: IE added
Milestone: CKEditor 3.4.2
Status: newconfirmed
Version: 3.4

Confirmed on Quirks mode.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6408.patch added

comment:2 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:3 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5924].

comment:5 Changed 7 years ago by Dinu

Version: 3.43.4.2

Reopen: not fixed
Test: IE8/IE8 Standards, IE8 Compat/IE7 Standards

Problem:
CKEDITOR.env.ie&&CKEDITOR.env.quirks?0:24
Should (probably?) be the other way around:
CKEDITOR.env.ie&&CKEDITOR.env.quirks?24:0

Side comment:
According to http://msdn.microsoft.com/en-us/library/ms533687(VS.85).aspx compatMode is deprecated, use documentMode if available for quirks mode detection. Haven't tested, just a thought.

comment:6 Changed 7 years ago by Dinu

Side note 2: CKEDITOR.env.ie&& is redundant

comment:7 Changed 7 years ago by Garry Yao

Test: IE8/IE8 Standards, IE8 Compat/IE7 Standards

It works for me for those modes, could you attach a screenshot/screencast?

Changed 7 years ago by Dinu

Attachment: 24px.jpg added

comment:8 Changed 7 years ago by Dinu

Done. Your written code does this: adds 0px if the browser IS in quirks mode and 24px if it's in standards mode. Shouldn't it be the other way around?

Changed 7 years ago by Dinu

Attachment: 6408_2.patch added

comment:9 Changed 7 years ago by Dinu

Please review... one simple thing less to maintain.

comment:10 Changed 6 years ago by Dinu

Bump. Again need to repatch release.

comment:11 Changed 6 years ago by Garry Yao

Please avoid adding comments to fixed ticket, #7173 has been opened for all issues mentioned.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy