Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6417 closed Bug (fixed)

Context menu jumps into upper-left corner of edit area under IE9

Reported by: Krzysztof Studnik Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: UI : Context Menu Version: 3.1
Keywords: IE Cc:

Description

  • Open CKEditor
  • right-click in edit area

Context menu jumps to upper left corner of edit area

Attachments (3)

krst 10.57.43 .avi (55.5 KB) - added by Krzysztof Studnik 7 years ago.
6417.patch (751 bytes) - added by Garry Yao 7 years ago.
6417_2.patch (1.8 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by Krzysztof Studnik

Attachment: krst 10.57.43 .avi added

comment:1 Changed 7 years ago by Tobiasz Cudnik

Keywords: IE added; IE9 removed
Milestone: CKEditor 3.4.2

comment:2 Changed 7 years ago by Garry Yao

Status: newconfirmed

Bump, 'contextmenu' DOM event have no offset information under IE9 ;), this definitely desires a bug report to MS.

comment:3 Changed 7 years ago by Alfonso Martínez de Lizarrondo

A ticket already exists: https://connect.microsoft.com/IE/feedback/details/590368/clientx-clienty-and-pagex-pagey-properties-are-missing-on-contextmenu-events

The problem is that by default we try to the w3c event model which IE9 does support, but at least in this case their behavior lacks almost all the interesting info.

We could fix it by changing the detection order in domobject.js, but I would prefer not to do that as it's a bug in IE9 that will affect a bunch of sites.

comment:4 Changed 7 years ago by Garry Yao

@alfonsoml, thanks for the confirmation ( I can't find the bug page), I'm thinking on the opposite side of you actually, apparently that MS cares of back-compatibility more than meeting standards, so we should be more conservation here.

Changed 7 years ago by Garry Yao

Attachment: 6417.patch added

comment:5 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Status: reviewreview_failed

This is not a back-compatibility problem for IE code, if we use the IE code path there's no compatibility problem, but they have added new code implementing the W3C event model and they have a bug in their implementation that makes their code incompatible with other browsers and all the deployed code. So they must fix it: they don't get anything good from preserving this bug, not a single website will behave wrong by fixing it.

On the other hand, the patch is wrong because it would need to also change the order in removeListener.

I still think that we must wait before changing this so we can test the full W3C model with IE9, and postpone the milestone for this ticket.

comment:7 Changed 7 years ago by Garry Yao

Status: review_failedreview

@alfonsoml, I understand your point, IE9 is still in beta that theoretically we should wait, but some of our clients are measuring our IE compatibility based on their observation of the editor behavior on this new IE9 beta, so we can't really wait for 4 month (even more?) to make them smile. In case there're no known problem now for the old event model, it's safe to just use that.

Changed 7 years ago by Garry Yao

Attachment: 6417_2.patch added

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

I understand your point of "making the web better" Alfonso, but It's certainly safe to proceed with this, considering that we're just changing the order of the feature check.

comment:9 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [5971].

comment:10 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Microsoft has already fixed the problem in the last Preview 6.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy