Opened 12 years ago

Closed 12 years ago

#648 closed Bug (fixed)

<p> and <div> tag are crazy

Reported by: andreescudero@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: jagprieto@…

Description

This 2.0RC2 version is puting a </p> tag in <div></div> like this:

<div> blabla </p> </div> and this: <p>blabla<p>blabla</p></p>

These erros are causing some problems , reported by some user (please, see this forum): https://sourceforge.net/forum/forum.php? thread_id=1201918&forum_id=379487

In my opinion, it is a very hard bug. Do you have some idea to solve this?

Bests regards, Andr�


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1104285&group_id=75348&atid=543653

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Cc: jagprieto@… added
Reporter: changed from Martin Kou to andreescudero@…

Hi,

the problem is only with <p> and <div> tag, I think. Please, see the file attashed in this forum: http://sourceforge.net/tracker/index.php?func=detail&aid=1105601&group_id=75348&atid=543653

The text start with:

<p><strong><font face="Verdana" color="#990000">
[POZDRAV] 
[IME]!                                                                    
      
           19.01.2005.</font></strong></p><p><font 
face="verdana,arial,helvetica,sans-serif" color="#333333" 
size="2"><p><span>

So, a <p><span> inside in a <p> tag

Thanks, Andr�


Moved from SF. Original poster: andreescudero

Hi...

You also have an error with fckeditor if value on the text box is like

<p></p>
<h1></h1>
<ul></ul>
............

So it's impossible to open the fckeditor on this cases


Moved from SF. Original poster: jagprieto

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

This shouldn't be an issue anymore with our SVN version.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy