Opened 10 years ago

Closed 10 years ago

#6529 closed Bug (fixed)

Basic style cannot be re-applied

Reported by: Tobiasz Cudnik Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: Core : Styles Version: 3.4.2
Keywords: Cc:

Description

Basic style cannot be re-applied, a regression since 3.4.1.

  1. Use a following content:
    <p>
    	<strong>this [is</strong> some] sample text</p>
    
  2. Press the Bold button, to remove a bold style.
  3. Press the Bold button again, to apply it on the selection.

Expected: The bold text is "this is some".

Result: The bold text is "this".

Relevant UnitTest: test_inline14

Attachments (2)

6529.patch (937 bytes) - added by Garry Yao 10 years ago.
6529_2.patch (844 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Sa'ar Zac Elias

Component: GeneralCore : Styles
Status: newconfirmed

comment:2 Changed 10 years ago by Paweł Horzela

The issue was introduced in [5994].

comment:3 Changed 10 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

Changed 10 years ago by Garry Yao

Attachment: 6529.patch added

comment:4 Changed 10 years ago by Garry Yao

Owner: changed from Paweł Horzela to Garry Yao
Status: assignedreview

comment:5 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

Using the same TC and trying to remove the newly created element doesn't work. This is caused by the change of L888.

Changed 10 years ago by Garry Yao

Attachment: 6529_2.patch added

comment:6 Changed 10 years ago by Garry Yao

Status: review_failedreview

Nice catch.

comment:7 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6030].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy