Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6545 closed Bug (fixed)

Safari: new paragraph is being added automatically

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.4.2
Keywords: Mac Safari Cc: gav@…

Description (last modified by Wiktor Walc)

When clicking between two paragraps an empty space is added automatically.

Steps to reproduce

Issue 1

  • Open "Replace by Class Name" sample
  • Paste the following in source mode:
    <p>
    	This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
    <p>
    	This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
    <p>
    	This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
    
  • Click on the second line (for example on "some").
  • Result:

An empty paragraph was added to the source:

<p>
	This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
<p>
	This&nbsp;is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
<p>
	&nbsp;</p>
<p>
	This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>

Issue 2

If you follow the steps above, but click between "This" and "is" in the second paragraph, an empty space is replaced with "&nbsp;". It seems to be related and caused by the same bug.

Looks like a regression, cannot reproduce it in 3.4.1.

Attachments (1)

6545.patch (765 bytes) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by Wiktor Walc

Description: modified (diff)

comment:2 Changed 9 years ago by Krzysztof Studnik

Status: newconfirmed

Confirmed for Safari 4/Mac

comment:3 Changed 9 years ago by Garry Yao

Regression of [5907].

comment:4 Changed 9 years ago by Garry Yao

New line is also created when pasting in the middle of a paragraph.

comment:5 Changed 9 years ago by George Vilches

Cc: gav@… added

Changed 9 years ago by Garry Yao

Attachment: 6545.patch added

comment:6 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Auto scrolling should be happen on focus at all, other browsers are all not behaving like that.

comment:7 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

You can also add (#6153) to the comment on L639 for future reference.

comment:8 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6027].

comment:9 Changed 9 years ago by Krzysztof Studnik

WFM for Safari5 mac

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy