Opened 8 years ago

Closed 7 years ago

#6551 closed Bug (wontfix)

[IE7]: Improper behaviour when pasting a List in IE7

Reported by: James Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.0
Keywords: IBM IE VendorFix Cc: Damian, joek, Satya Minnekanti

Description

Steps to reproduce the defect:

  1. Open the Ajax sample in IE7.
  2. Create the following multi-layered numbered list.
    <ol>
    	<li>item 1</li>
    	<li style="margin-left: 40px">item 2</li>
    	<li style="margin-left: 80px">item 3</li>
    </ol>
    
    
  3. Press CTRL + A and then CTRL + C to copy the list.
  4. Press CTRL + A and then CTRL + V to paste the list, replacing the list that is currently in the editor.

Expected: The pasted list should be identical to list that was copied.

Actual: The pasted list contains an extra number and ~ (tilda). (see attachment)

Attachments (2)

pasted list defect.jpg (25.2 KB) - added by James 8 years ago.
6551_tc.html (557 bytes) - added by Wiktor Walc 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by James

Attachment: pasted list defect.jpg added

comment:1 Changed 8 years ago by Garry Yao

Status: newconfirmed

Ok, though we can't guarantee that the original list will be overwritten entirely (browser dependent), we should have at least no extra characters.

comment:2 Changed 8 years ago by Garry Yao

Milestone: CKEditor 3.5.1

comment:3 Changed 8 years ago by Garry Yao

Keywords: IE added; IE7 removed

Confirm that the tilda was ridiculously added by the browser, so we should instead report a bug that affects all IE versions.

comment:4 Changed 8 years ago by Damian

I couldn't reproduce this in IE-only using the folowing test file (i.e. no CKEditor):

<div contenteditable="true">
	<ol>
		<li>item 1</li>
		<li style="margin-left: 40px">item 2</li>
		<li style="margin-left: 80px">item 3</li>
	</ol>
</div>

This makes me suspicious that the problem might be in CKEditor or related to CKEditor. Do you have an IE only test case that could form the basis of a bug report against IE?

Changed 8 years ago by Wiktor Walc

Attachment: 6551_tc.html added

comment:5 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.5.1
Version: 3.4.23.0

Check the attached HTML file. No CKEditor, the bug is still there when pasting the list.

comment:6 in reply to:  5 Changed 8 years ago by Satya Minnekanti

Replying to wwalc:

Check the attached HTML file. No CKEditor, the bug is still there when pasting the list.

@wwalc Could you please log a defect with Microsoft for this issue.

comment:7 Changed 7 years ago by Satya Minnekanti

@wwalc any update on this ticket. could you please log a ticket with Microsoft for this issue

comment:8 Changed 7 years ago by Garry Yao

Keywords: VendorFix added
Resolution: wontfix
Status: confirmedclosed

IE feedback reported.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy