Opened 8 years ago

Closed 8 years ago

#6574 closed Bug (fixed)

Opera: impossible to use keyboard after opening the context menu

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.4
Keywords: Opera Cc:

Description (last modified by Wiktor Walc)

Arrow keys work only for the first time an arrow key is pressed, after that it is impossible to use keyboard.

steps to reproduce

  • Create a table in wysywig mode (it's a nice object to test nested context menu items)
  • click inside of a table cell
  • press Shift + F10
  • press down arrow to "Cell"
  • press "Right arrow" key and then "Left arrow" key
  • result: if you press right arrow key again, the sub menu will not show up again. Pressing "esc" key doesn't close the context menu, so it is impossible to get back to the editing area.

I think I'm able to reproduce a similar bug at least since 3.4, although the effect is a little it different there.

Attachments (2)

6574.patch (511 bytes) - added by Garry Yao 8 years ago.
6574_2.patch (953 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by Wiktor Walc

Description: modified (diff)

comment:2 Changed 8 years ago by Wiktor Walc

Status: newconfirmed

comment:3 Changed 8 years ago by Wiktor Walc

Description: modified (diff)
Summary: Opera: arrow keys stop workingOpera: impossible to use keyboard after opening the context menu

Changed 8 years ago by Garry Yao

Attachment: 6574.patch added

comment:4 Changed 8 years ago by Garry Yao

Milestone: CKEditor 3.4.2
Owner: set to Garry Yao
Status: confirmedreview

comment:5 Changed 8 years ago by Tobiasz Cudnik

It seems to fix the problem, although there is still a flickering effect, while switching visible sub-menu (L, B, R arrows). Do you think we can handle this easily ? Even if not, it's an R+.

comment:6 Changed 8 years ago by Garry Yao

That's related to [5686], the new patch tackles it.

Changed 8 years ago by Garry Yao

Attachment: 6574_2.patch added

comment:7 Changed 8 years ago by Tobiasz Cudnik

Status: reviewreview_passed

comment:8 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6033].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy