Opened 12 years ago

Closed 7 years ago

#658 closed Bug (fixed)

Half text-lines when resizing (IE)

Reported by: michaelsoft@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF IE Cc: Frederico Caldeira Knabben, michaelsoft@…, jsjacob@…

Description

I have placed the FCKeditor in a HTML table. The table adds a frame around the editor with a caption etc. The table is set to 100% so it will resize with the browser window. The editor is also set to 100% and will also resize.

In this configuration, the editor sometimes clips the second text line, so that everything above the 'baseline' is not visible. See attached image for an example. When the cursor is moved, the line is redrawn. But when the browser window is resized, the line dissapears again.

This problem was not noticed when the editor was not in a table and/or not resizable.

Anyone an idea for a fix or workaround?

Regards, MichaelSoft AD Hosting.nl


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1196437&group_id=75348&atid=543653

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to michaelsoft@…

It seams it got fixed in IE7 at least. Let's try to find out something for IE6.


Moved from SF. Original poster: fredck

This test case indeed shows the problem. The original report was related to an older version of the editor. The current version will remove a whole block of text. Just tested in IE7, and the missing text is flashing on and off while resizing. But it is always displayed at the end. Thank you Jacob!


Moved from SF. Original poster: michaelsoft

Ok... your test case makes is always reproducible. It shows a different behavior then that described in the report, but I think it is quite related.

This is a good step to try to find out a solution for it. Thanks for it.


Moved from SF. Original poster: fredck

I forgot to add: after pasting the code in as source, go back to WYSIWYG mode.


Moved from SF. Original poster: jsjacob

How do I attach a file? I have a reproducible case (at least for me). Paste this code as source into the FCKeditor demo at http://www.fckeditor.net/demo using IE (I'm still on IE 6). Resize the window. You should see multiple lines disappear. Click on the empty lines and they reappear.

<p><img align="right" alt=""
src="http://www.iamnota.com/gallery/d/6552-2/IMG_3899.JPG" />Lorem ipsum
dolor sit amet, consectetuer adipiscing elit. Pellentesque euismod. Vivamus
aliquet suscipit leo. Morbi nisi ante, tincidunt id, tempor id, euismod ac,
nibh. Nam ut pede. Suspendisse elementum, leo vitae porttitor tempor, lacus
felis auctor lacus, non aliquam metus enim ac nisl. Sed aliquam sem vitae
nibh. Suspendisse pretium sagittis eros. Nam ornare rhoncus mi. Suspendisse
interdum, lorem non ultricies sodales, orci sem lobortis massa, at feugiat
neque lectus quis lacus. Nulla nisi libero, rutrum eget, facilisis ac,
venenatis bibendum, ipsum. Ut convallis leo at dolor.</p>

Moved from SF. Original poster: jsjacob

I feel this is something we'll have problems to fix in any case. It seams to be some IE bug on rendering. Without a reproducible test case, it is impossible to propose any fix.

I'll leave this one opened for a while, but if we don't get any further results, I'll be forced to close it, moving the problem to the "Known Issues Limbo" (a special tracker will be opening in the future with issues mainly related to browser bugs, to which we are not able to propose fixes).

Thanks again for your comments.


Moved from SF. Original poster: fredck

Hi Fredck, I'm using the editor also for my latest projects. The problem is very difficult to get pin-pointed. Today I opened the editor with some formatted content and was missing the whole bottom half... re-tracing my steps I couldn't reproduce it. Your request for a simple test case is a sleeping threat in my head that is triggered every time I notice the problem. I'm just glad that someone else has the same problem, maybe they can help simplify the case.

On the other hand, maybe it is solved in IE7 ;-)


Moved from SF. Original poster: michaelsoft

I renew my request for a simple test case file.


Moved from SF. Original poster: fredck

We are seeing this in our use of FCKeditor as well. Text disappears until the mouse is moved over it and clicked. It happens only in IE.


Moved from SF. Original poster: Anonymous

I had also testes the display thing with no problems. It is quite difficute to investigate further without a test case file. Don't you think you can create a similar page without the Ajax things (by simply setting the editor value with any value). This would be the best way to proceed with it... you may also point us to a sample URL were we can see the problem.


Moved from SF. Original poster: fredck

The current version I'm using (version 2.3, Build 1054) is better, but still has the same problem. However it is difficult to supply you with same HTML code. Currently I'm using AJAX like pages. In first instance the editor is not shown. After the user presses a button the correct text is inserted into the editor (SetHTML) and the editor is show (style.display = ) while the current display is hidden (style.display = 'none'). This situation generates various effects, like that the editor is not shown at all but appears suddenly when moving the mouse (solved with a work-around). But the half- line is the biggest nuisance.

I'm sure that these problems are very IE6 related, but all of my users are (simple minded Windows XP users and therefore) IE related.


Moved from SF. Original poster: michaelsoft

I've tried to reproduce it here with the latest version with no success. Is it still an issue? If yes, can you provide a sample HTML page with the editor to help on the tests?

Thanks in advance.


Moved from SF. Original poster: fredck

comment:2 Changed 12 years ago by Martin Kou

Keywords: Confirmed IE added

I could still reproduce the problem with jsjacob's test case in IE6 with the current 2.5 SVN code.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

FCKeditor is not supported anymore, CKEditor 4 doesn't support IE6 and I was not able to reproduce this problem in CKEditor thus closing this issue as fixed (fixed in CKE and new IE versions).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy