Opened 9 years ago

Closed 9 years ago

#6596 closed Bug (fixed)

[IE9] anchor and hidden field insertion is broken

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.5.3
Component: UI : Dialogs Version:
Keywords: IE9 Cc:

Description (last modified by Wiktor Walc)

It's not able to insert anchor and hidden field in IE9.

Change History (9)

comment:1 Changed 9 years ago by Garry Yao

Keywords: IE added
Status: newconfirmed

comment:2 Changed 9 years ago by Alfonso Martínez de Lizarrondo

The patch in #3582 works correctly for IE9

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4.3CKEditor 3.6

Let's have them together at this point.

comment:4 Changed 9 years ago by Garry Yao

Resolution: duplicate
Status: confirmedclosed

Will be handled at #3582.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6

comment:6 Changed 9 years ago by Alfonso Martínez de Lizarrondo

I guess that it would be better to reopen this one and apply just the IE9 part. I think that the "hidden input" dialog had the same problem.

comment:7 in reply to:  6 Changed 9 years ago by Krzysztof Studnik

Keywords: IE9 added; IE removed
Resolution: duplicate
Status: closedreopened

Replying to alfonsoml:

I guess that it would be better to reopen this one and apply just the IE9 part. I think that the "hidden input" dialog had the same problem.

I agree that we should have different ticket open to IE9. We could always close this one and #3582 together if issue is resolved.
===Additional info === #7191 is a DUP
Rechecked under IE9 Final /CKE rev 6559 - problem still occurs.
When OK button is pressed, following error is shown in console:

SCRIPT5022: DOM Exception: INVALID_CHARACTER_ERR (5) 
ckeditor.js, line 15 character 301

comment:8 Changed 9 years ago by Wiktor Walc

Description: modified (diff)
Milestone: CKEditor 3.5.3
Status: reopenedconfirmed
Summary: [IE9] anchor insertion is broken[IE9] anchor and hidden field insertion is broken

As Alfonso already mentioned, it is also impossible to insert a hidden input element due to the same error.

SCRIPT5022: DOM Exception: INVALID_CHARACTER_ERR (5) 
element.js, line 29 character 3

comment:9 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Fixed with macro change [6567].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy