Ticket #6604 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Bidi and Justify plugins should create the same element [enterMode BR]

Reported by: Saare Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.1
Component: General Version: 3.0
Keywords: Discussion Cc:

Description

Currently, when enterMode is BR, justifying text results in a paragrpah, and adding direction results in a DIV. In both cases paragraph should be used.

Attachments

6604.patch (1.1 KB) - added by garry.yao 3 years ago.

Change History

comment:1 follow-up: ↓ 3 Changed 3 years ago by fredck

Please note that with enterMode BR, all block like operations must result in a <div>, not a <p>. This is by design.

comment:2 Changed 3 years ago by fredck

  • Milestone changed from CKEditor 3.4.3 to CKEditor 3.5.1

comment:3 in reply to: ↑ 1 Changed 3 years ago by garry.yao

  • Keywords Discussion added

Replying to fredck:

Please note that with enterMode BR, all block like operations must result in a <div>, not a <p>. This is by design.

I'm sure this's not respected at all in v3, works like you describe in v2 though, so looks like a serious bug.

comment:4 Changed 3 years ago by garry.yao

  • Status changed from new to confirmed
  • Version set to 3.0

comment:5 Changed 3 years ago by tobiasz.cudnik

So what is the issue here? Plugins which are using P for "block like operations" in entermode BR?

Changed 3 years ago by garry.yao

comment:6 Changed 3 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao

comment:7 Changed 3 years ago by Saare

  • Status changed from review to review_passed

comment:8 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6273].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy