Ticket #6653 (closed Bug: fixed)

Opened 3 years ago

Last modified 13 months ago

Multi-line Paste Bug in OS X Safari

Reported by: rpetrello Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.1
Keywords: Safari Mac Cc: mattleff@…

Description

I've uncovered a bug when pasting from certain OS X applications into a CKEditor form element in Safari. Here's one way to reproduce the bug:

  • Open a new email in Apple Mail.
  • Type a multiple-line message.
  • Copy all of the content with Cmd-A, Cmd-C.
  • Paste into any CKEditor form element using Cmd-V.
  • The pasted content is truncated at the first line.

Here's a video showing the bug in action:

http://www.screencast-o-matic.com/watch/c6Xj2r6to

I'm currently running:

  • CKEditor 3.4.2
  • Mac OS X 10.6
  • Apple Safari 5.0.2

Worth noting is that I was not able to reproduce this bug in Firefox or Google Chrome on OS X. Also, I'm able to copy and paste multiline content from *some* applications just fine (most text editors, and even the Safari browser itself).

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Keywords Safari Mac added
  • Version changed from 3.4.2 to 3.1

I have checked it under Safari 5.0.5. The problem still occurs.

Reproducible from CKEditor 3.1.

From CKEditor 3.1 till 3.2 (inclusive), text pasted from Mail was visible for a split of a second and then truncated.

comment:2 Changed 3 years ago by mattleff

  • Cc mattleff@… added

+1 This is still reproducible with Safari 5.1 on Lion and the current CKEditor demo.

comment:3 Changed 13 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

Expired - entire content is pasted. Unfortunately produced HTML is awful, but this is caused by Safari and we cannot fix that. The only rescue is Advanced Content Filter when editor is configured to not accept divs - then they are transformed to paragraphs.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy