Opened 8 years ago

Closed 5 years ago

#6668 closed New Feature (fixed)

Image resize plugin

Reported by: Dinu Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Discussion Webkit Drupal Cc: wim.leers@…

Description

I guess it's known but I couldn't find a related report: there's no image resize in Opera, Safari, Chrome. I guess browser support and/or a plugin is needed?

Change History (19)

comment:1 Changed 8 years ago by Krzysztof Studnik

Keywords: Discussion added
Status: newconfirmed
Version: 3.4.23.0

Confirmed. Under Opera and Webkit browsers, the only way to resize an image, is opening image properties.
Under IE and FF, when image is selected, a resize border shows around it. Is it browser engine related feature?

comment:2 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Yes, it's a browser feature. This is the ticket for webkit: https://bugs.webkit.org/show_bug.cgi?id=12250 I think that there might be other ticket here for Opera

comment:3 in reply to:  2 Changed 8 years ago by jonjbar

Replying to alfonsoml:

Yes, it's a browser feature. This is the ticket for webkit: https://bugs.webkit.org/show_bug.cgi?id=12250 I think that there might be other ticket here for Opera

This might be a browser feature however this can and should be implemented by CKEditor. Try to resize an image on Google Docs Editor using Chrome or Safari, it is working fine so there is a way to "fake" it.

This is a very high priority problem as this is a very important feature and WebKit based web browser are not negligible anymore. Furthermore, it looks like nobody is working on that feature from the WebKit bug mentioned earlier.

comment:4 Changed 7 years ago by styu

+1 for the plugin based solution.

comment:5 Changed 7 years ago by Gordon

Hi, I think dragging to resize image and table is a very important feature, but sadly it is not available for webkit browsers. Chrome is very popular now so please add this function. I may switch to TinyMCE since it has this feature in Chrome. I like ckEditor more, but my customers' complains are killing me.

comment:6 Changed 6 years ago by bnw

Hi, this bug is still present and imo critical. Any word on whether it will be fixed?

comment:7 Changed 6 years ago by jonjbar

It looks like the TinyMCE team has implemented the suggested work-around recently:
http://www.tinymce.com/forum/viewtopic.php?id=29222

comment:8 Changed 6 years ago by Nathan Haug

I found a plugin on Github that addresses the problem by emulating resizing handles (similar to the tinyMCE approach). I forked it to port it to CKEditor 4.x and clean up a few issues I found. Here's my version: https://github.com/quicksketch/ck-webkitdrag

The code formatting isn't inline with CKEditor's standards (the original wasn't either). I'd be happy to reformat if its possible to include in the project, but I don't know if it's better to keep as a separate plugin or not. It seems like it would be optimal to leave it separate, as Webkit could fix the problem at any time.

comment:9 Changed 6 years ago by Jakub Ś

@quicksketch To get your proposed fix tested and applied (if it is correct) please fork CKEditor 4 code from https://github.com/ckeditor/ckeditor-dev, prepare your fix and make a "pull request" (here is the example list of pull requests https://github.com/ckeditor/ckeditor-dev/pulls?direction=desc&page=1&sort=created&state=open).

comment:10 Changed 6 years ago by Piotrek Koszuliński

Keywords: Webkit added
Milestone: CKEditor 4.1

Hi,

Thanks for your contribution.

I advice you to add your plugin to our new Addons repo - http://ckeditor.com/addons/plugins/all. Thanks to the new online builder (http://ckeditor.com/builder) it will be easily available for others.

We can consider adding this plugin to core in the future (4.1 is the earliest possible release), especially that resizing is available only on FF and IEs (so we're missing it on Opera too), but it's always better to keep core as small as possible, because adding and maintaining new plugin adds some amount of work. E.g. I think that we may be obligated to add a11y support for non-native resizing.

Anyway, I'm adding 4.1 milestone for now - we need to discuss what's the best option.

comment:11 Changed 6 years ago by Nathan Haug

Thanks both of you for your help. I agree that including the plugin in the plugins repository is probably the best immediate solution. Since I didn't originally write the plugin, I'll contact the original author to see if he'd be willing to submit it to the repository.

@j.swiderski: I wasn't sure how deeply CKEditor had moved to Github practices and if a pull request would be the correct approach (rather than a patch here). Thanks for clarifying.

comment:12 Changed 6 years ago by Frederico Caldeira Knabben

I was wondering if all handlers are needed. Wouldn't it be enough the bottom-right corner only (bottom-left on RTL image)?

comment:13 Changed 6 years ago by Frederico Caldeira Knabben

Type: BugNew Feature

comment:14 Changed 6 years ago by Dinu

I can see no use of dragging the top edge, unless you support positioned elements. Dragging the left edge however in LTR, could be useful for right-floated images (which CK does support). Dragging the right edge of such element on the other hand, makes absolutely no sense. So I think you're safe with only one bottom corner, but you need to consider also float position to pick one.

comment:15 Changed 6 years ago by Wim Leers

Cc: wim.leers@… added

comment:16 Changed 6 years ago by Jakub Ś

replying to fredck

I was wondering if all handlers are needed. Wouldn't it be enough the bottom-right corner only (bottom-left on RTL image)?

Hmm... image can be put in different places of page, only its upper corner may be visible or user can simply decide that he wants to e.g. expand image height or width only.
Taking the above into account I think that all handles should be implemented, otherwise solution will be incomplete and users will still complain about it.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:17 Changed 6 years ago by Wiktor Walc

Keywords: Drupal added

comment:18 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.1

comment:19 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed in CKEditor 4.3 by introduction of image2 plugin.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy