Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6669 closed Bug (wontfix)

HTML code not inserting in IE, Inserting in FireFox

Reported by: Raghavendra Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Cc: raghavendra.ps@…

Description (last modified by Tobiasz Cudnik)

Hi,

I'm trying to insert a piece of HTML code in to Ckeditor.

The Html code looks like as follows

<sct-component id='475398579878' target-name=' TragetName' > Targetname </sct-component>

we are inserting this piece of html code using the following code

var htmlValue = CKEDITOR.dom.element.createFromHtml(htmlString); CKEDITOR.instances[ckInstanceName].insertElement(htmlValue);

The above piece of code insering the html code (above mentioned html tag) in to the ck editor in firefox but not in IE.

Is there any way that we can insert html code in to ck editor which will work in both the browsers?

Regards, Raghavendra.

Change History (4)

comment:1 Changed 9 years ago by Raghavendra

Hi,

I'm trying to insert a piece of HTML code in to Ckeditor.

The Html code looks like as follows <sct-component id='475398579878' target-name=' TragetName' > Targetname </sct-component>

we are inserting this piece of html code using the following code

var htmlValue = CKEDITOR.dom.element.createFromHtml(htmlString); CKEDITOR.instances[ckInstanceName].insertElement(htmlValue);

The above piece of code insering the html code (above mentioned html tag) in to the ck editor using firefox client but not using IE client.

Is there any way that we can insert html code in to ck editor which will work using both the browsers?

Regards, Raghavendra.

comment:2 Changed 9 years ago by Tobiasz Cudnik

Description: modified (diff)
Status: newconfirmed

It seems that IE creates it as text node.

comment:3 Changed 9 years ago by Tobiasz Cudnik

Resolution: wontfix
Status: confirmedclosed

IE can't handle custom tags, you should try extending the DTD, this may help.

comment:4 in reply to:  3 Changed 9 years ago by Raghavendra

Replying to tobiasz.cudnik:

IE can't handle custom tags, you should try extending the DTD, this may help.

can you please explain how can I do this or Will it work if I use protected tags.

If so please let me know how can i use protected tags.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy