Opened 8 years ago

Closed 8 years ago

#6681 closed Bug (fixed)

Firefox: unable to insert a link after deleting it

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox Cc: jehrenzweig@…

Description

  1. Go to http://ckeditor.com/demo
  2. Click the “New Page” icon
  3. Click on the “Link” icon, paste a URL into the field, and click the “OK” button. The hyperlinked URL will appear in the CKEditor, as expected.
  4. Click the “Delete” keyboard button (aka Javascript keycode = 46).
  5. Click on the “Link” icon, paste a URL into the field, and click the “OK” button.
  6. Problem: the URL does not get pasted into the CKEditor, nor does it appear in the HTML source code.

However, if you repeat this process and click the “Backspace” keyboard button (aka Javascript keycode = 8) in Step 4, everything works properly.

It seems that it never worked properly so I'm setting the version to 3.0, although in earlier versions (<3.2) the (invalid) result was different (due to #4886).

Change History (4)

comment:1 Changed 8 years ago by Wiktor Walc

Cc: jehrenzweig@… added

comment:2 Changed 8 years ago by Garry Yao

Keywords: Firefox added
Status: newconfirmed

The problem is that FF leave an empty link element after "Delete" key pressed, WFM in all other browsers.

comment:3 Changed 8 years ago by Wiktor Walc

Status: confirmedpending

I'm unable to reproduce it now using CKEditor 3.6.1 in Firefox 3.6.18. Can you confirm it as well? It looks like the link is correctly deleted after pressing "Delete" key now.

comment:4 Changed 8 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

Can't reproduce it either. It seems that it was fixed in CKE 3.5.1

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy