Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6722 closed Bug (wontfix)

Issue with styling when Img and <a> tags are present.

Reported by: naresh.sivaraman Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: IE6 Oracle Cc:

Description

Found in IE6.

1.Open CKEditor with IE6

  1. click [Image], then set the following ImageInfo: URL = <any URL of image> Link: URL = <any URL of Web page> Advanced: Style = "border: double red"
  1. The image is shown correctly with double border at this time.

But going to source and coming back to WYSIWYG makes the border 'single'.

This seems like an IE6 issue and looks like special checking needs to be done on the CKEDITOR code(for IE6) for this scenario.

When Image is added without the hyperlink, with the double border, the functionality is fine. The double border is intact.

Change History (5)

comment:1 Changed 9 years ago by Garry Yao

Keywords: IE6 added
Status: newconfirmed

comment:2 Changed 9 years ago by Wiktor Walc

Keywords: Oracle added

comment:3 Changed 9 years ago by Garry Yao

Resolution: wontfix
Status: confirmedclosed

It's not an IE6 specific issue, not even an IE one, just the way how browser display link around an image, where the image border and link decoration is merged, there's no CSS fix for that AFAIK.

comment:4 Changed 9 years ago by naresh.sivaraman

Garry,

Noticed something -

When the source is like this, IE6 displays the borders properly:

(1) <p><a href="www.google.com"><img alt="" src="blah" style="border-right: red double; border-top: red double; border-left: red double; border-bottom: red double"/></a></p>

OR

(2) <p><a href="www.google.com"><img alt="" src="blah" style="border: medium double red;"/></a></p>

But CKEDITOR uses this html and this not does display the double border:

(3) <p><a href="www.google.com"><img alt="" src="sdfsf" style="border-left-color: red; border-bottom-color: red; border-top-style: double; border-top-color: red; border-right-style: double; border-left-style: double; border-right-color: red; border-bottom-style: double"/></a></p>

And pasting the correctly working ones(1 or 2) in 'Source mode' and going to 'WYSIWYG' and coming back to 'Source' shows that the html has been changed to the not-proper one(3).

Please check the same. It looks like a CKEDITOR issue.

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

IE itself transforms style declarations when we load the editable contents on it. This is out of our control. Then an IE6 bug limits the style usability. That's also out of our control.

I would recommend you trying to find different ways to style these elements. May CSS and class would help on this.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy