Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6721 closed Bug (invalid)

In IE7, edit area adding <p>&nbsp</p> elements when clicking in the edit area

Reported by: Senthil Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Oracle Cc: Senthil

Description

In IE7, open nightly sample and add a table with default settings. Select the source control and again click it to go back to non source mode. Now do the mouse click on the top left corner of the editing area, just above the table.

Results in a new <p>&nbsp</p> being added to the document.(screen shot is attached)

Attachments (1)

issue.PNG (66.7 KB) - added by Senthil 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Senthil

Attachment: issue.PNG added

comment:1 Changed 9 years ago by Senthil

Also we need look for other elements(like <hr> element) for this issue.

comment:2 Changed 9 years ago by Senthil

Also inserting <tr> or <td> alone in source mode and switching between the source and non source inserting the "<p>&nbsp;</p>" elements automatically and document grows with every subsequent click.

comment:3 Changed 9 years ago by Garry Yao

Resolution: invalid
Status: newclosed

For the problem described in ticket was actually a feature by design which makes it easier for user to put cursor above/below table which is originally impossible in some browsers, while some users don't like it (just like you), so we have #6654 to allow it to be dismissed.

comment:4 in reply to:  2 Changed 9 years ago by Garry Yao

Replying to Senthil:

Also inserting <tr> or <td> alone in source mode and switching between the source and non source inserting the "<p>&nbsp;</p>" elements automatically and document grows with every subsequent click.

Please don't open one ticket to describe two problems.

comment:5 Changed 9 years ago by Senthil

Garry: Regarding your comment on "For the problem described in ticket was actually a feature by design which makes it easier for user to put cursor above/below table", actually one of our customer is getting the newline while putting the cursor above the bulleted list not on the table. So is this also expected behavior?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy