Ticket #6777 (closed Bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Image dialog: JavaScript error (invalid argument)

Reported by: wwalc Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

It can be reproduced on the demo page. The problem is caused by the "%25" character in the file name.

Steps to reproduce

  • Open the Image dialog
  • Paste the following in the URL field: /images/Test%25Image.jpg
  • Click "Ok" to close the dialog
  • Result: an error occurs, the image is not inserted into the document.
Invalid argument.  _source/com/dom/element.js, line 987 character 5

var standard = function( name, value )
{
	this.$.setAttribute( name, value ); // <-- line 987
	return this;
};

Change History

comment:1 Changed 3 years ago by wwalc

  • Status changed from new to confirmed

comment:2 Changed 3 years ago by wwalc

  • Status changed from confirmed to closed
  • Resolution set to duplicate

Looks like a dup of #5256

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy