Opened 12 years ago

Closed 12 years ago

#679 closed Bug (duplicate)

[SS] IE RemoveFormat ignores span tags

Reported by: carlolivier@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: Frederico Caldeira Knabben, nachtzuster70@…

Description

When using the standard Remove Format button provided by the editor in IE no <span></span> tags are removed.

This is due to the execCommand in IE I believe.

Firefox works fine - however many of my users are on IE.

The main issue this causes me is that I use integrated custom CSS classes in the Style select box - and I use <span> tags to insert the markup - which can never be "restyled" or removed - when using IE.

My only option it seems at this stage is to use the <font> tag for i inserting those styles - although thats terrible as its been deprecated! XHTML and all.

Anyway - has anyone got any ideas if this IS in fact an IE issue - or am I missing something?


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1326920&group_id=75348&atid=543653

Change History (3)

comment:1 Changed 12 years ago by Martin Kou

Cc: Frederico Caldeira Knabben nachtzuster70 added
Reporter: changed from Martin Kou to carlolivier@…

Marking it as [SS] Style Selector.


Moved from SF. Original poster: fredck

In my opinion it's a very big bug. For example, when two users are working on the same site with FCKEditor. The first user uses Mozilla Firefox, the second user Internet Explorer. The user with the IE can never remove these formats created by the first user with MOzilla FIrefox (span-Tags).

The problem is, that Mozilla Firefox uses these span-Tags to format the text, but Internet Explorer uses HTML-Tags to format it.


Moved from SF. Original poster: Anonymous

Still got this problem on IE. Has anyone found a solution for that bug ?

Mika


Moved from SF. Original poster: Anonymous

This is exactly my biggest problem as well. If you start a selfmade style using a span tag, you can never get out of it. And if you have already put a style around a word, you can't change style or get rid of it!! I use the editor in a simple CMS, and the whole point is that users can change their site, but not make a huge mess of it with colors and font-sizes... thats why those styles are so important. I really hope someone has the solutions for this. FCKeditor is great, but a workaround this wil make it even better.

ThePixelChick


Moved from SF. Original poster: nachtzuster70

comment:2 Changed 12 years ago by Martin Kou

Cc: nachtzuster70@… added; nachtzuster70 removed

comment:3 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: newclosed

This is a dup of #75

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy