Opened 7 years ago

Closed 7 years ago

#6791 closed Bug (fixed)

[IE7] Editor does not show in IE 7 when textarea name="description"

Reported by: Wes Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.5.1
Component: General Version:
Keywords: IE Cc:

Description

IE 7 ONLY

<textarea name="description">content here</textarea>

The rich editor will not initialize in IE 7 when the textarea's name is set to description.

Attachments (5)

6791_TC.html (579 bytes) - added by Frederico Caldeira Knabben 7 years ago.
Test case.
6791.patch (520 bytes) - added by Tobiasz Cudnik 7 years ago.
6791_2.patch (547 bytes) - added by Sa'ar Zac Elias 7 years ago.
6791_3.patch (1.2 KB) - added by Tobiasz Cudnik 7 years ago.
6791_4.patch (675 bytes) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 7 years ago by Wes

spent the last 4 hours trying to figure this out. hope it helps. There are a ton of related bug reports I found.

comment:2 Changed 7 years ago by Wes

Summary: Editor does not show in IE 7 when textarea name="description"[IE7] Editor does not show in IE 7 when textarea name="description"

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 6791_TC.html added

Test case.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: IE7 Internet Explorer initialize show removed
Milestone: CKEditor 3.5.1
Status: newconfirmed

I was about to open a ticket for it, as a follow up to this page:
http://extrafuture.com/2010/12/07/ckeditor-and-ie7/

The problem is related to the presence of a <meta name="description"> tag. In fact, any textarea with name matching meta tag names will be troublesome.

I've attached a TC for it. The problem can be confirmed in IE8 Compatibility mode as well.

I think we have dealt with this issue in v2 and the solution should be quite simple. It's just a matter of porting it to v3.

comment:4 Changed 7 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: confirmedassigned

Changed 7 years ago by Tobiasz Cudnik

Attachment: 6791.patch added

comment:5 Changed 7 years ago by Tobiasz Cudnik

Status: assignedreview

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_failed
  • Patch breaks the editor in pages where there's no element with an id of "description".

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6791_2.patch added

comment:7 Changed 7 years ago by Tobiasz Cudnik

Status: review_failedreview

comment:8 Changed 7 years ago by Garry Yao

Status: reviewreview_failed

Just to be sure, how about

element.tagName.toLowerCase() in CKEDITOR.dtd.head

Please always add back-ref comments to the ticket.

Changed 7 years ago by Tobiasz Cudnik

Attachment: 6791_3.patch added

comment:9 Changed 7 years ago by Tobiasz Cudnik

Status: review_failedreview

DTD approach seems to be more universal, attaching updated patch.

comment:10 Changed 7 years ago by Garry Yao

Status: reviewreview_failed

Let's inline DTD tag names for now, that would not change the footprint of ckeditor_basic.js

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6791_4.patch added

comment:11 Changed 7 years ago by Sa'ar Zac Elias

Owner: changed from Tobiasz Cudnik to Sa'ar Zac Elias
Status: review_failedreview

comment:12 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

comment:13 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6301].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy