Opened 7 years ago

Closed 3 months ago

#6819 closed Bug (fixed)

Pasting rich text in a table cell results in incorrect placement

Reported by: Jeremy Friesen Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.2
Keywords: Chrome Cc:

Description (last modified by Krzysztof Studnik)

If I copy the text in the editor area and paste the text into the cell, the result is that the text looks to have pasted into the proper location, but on switching to source mode, the text is in fact pasted immediately after the closing of the td element. Note, if I paste plain text into the table cell the behavior is as expected (i.e. the text is visually in the proper place and in source mode is contained in the td element)

<table border="1" cellpadding="1" cellspacing="1" style="width: 500px; ">
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			Text from the editor
			<td> 
                </tr>
</tbody>
</table>

Change History (3)

comment:1 Changed 7 years ago by Krzysztof Studnik

Component: GeneralCore : Pasting
Description: modified (diff)
Keywords: paste table removed
Status: newconfirmed
Version: 3.4.3 (SVN - trunk)3.2

Confirmed for Chrome 8 since CKE3.2,
When switching to Source - text is placed as above,
When switching back to WYSIWYG - text from table is moved to paragraph above table.

In rest of browsers works as expected

comment:2 Changed 7 years ago by Krzysztof Studnik

Keywords: Chrome added

comment:3 Changed 3 months ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I could no longer reproduce this issue in CKEditor 4.6.2 and Chrome 58

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy