Opened 9 years ago

Closed 9 years ago

#6820 closed Bug (fixed)

[IE] toolbar icons sprites 404s on editor load

Reported by: Garry Yao Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.4.3
Component: UI : Toolbar Version: 3.5
Keywords: IE Cc:

Description (last modified by Garry Yao)

Load the editor in IE7/8/9 note that there comes two 404s as shown in below timeline profile.

Attachments (5)

6820_ie_network_profile.png (38.1 KB) - added by Garry Yao 9 years ago.
6808.patch (14.2 KB) - added by Tobiasz Cudnik 9 years ago.
6820_IE8_strict_office2003.png (131.8 KB) - added by Garry Yao 9 years ago.
6820_2.patch (12.3 KB) - added by Tobiasz Cudnik 9 years ago.
6820_3.patch (13.4 KB) - added by Tobiasz Cudnik 9 years ago.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by Garry Yao

Attachment: 6820_ie_network_profile.png added

comment:1 Changed 9 years ago by Garry Yao

Description: modified (diff)

Regression of [5911].

comment:2 Changed 9 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:3 Changed 9 years ago by Tobiasz Cudnik

I'm affright that [5911] will have to be reverted, as the fix for #4821 doesn't really work, as AlphaImageLoader doesn't honor background-position property, so even if those image would be loaded, it wouldn't work. Additionally there are syntax errors for alpha(opacity=30).

Changed 9 years ago by Tobiasz Cudnik

Attachment: 6808.patch added

comment:4 Changed 9 years ago by Tobiasz Cudnik

Status: assignedreview

Seems that just a usage of a filter fixes zooming, so i've removed file sources and also reverted all changes to V2 and Office2003 skins, as they weren't affected.

comment:5 Changed 9 years ago by Garry Yao

Status: reviewreview_failed

Kinda of tricky, while non-kama still need this hack ;(

comment:6 Changed 9 years ago by Tobiasz Cudnik

You see some corrupted toolbar icons after zooming in IE using the V2 or Office2003 skin? As i can't reproduce it.

Changed 9 years ago by Garry Yao

Changed 9 years ago by Tobiasz Cudnik

Attachment: 6820_2.patch added

comment:7 Changed 9 years ago by Tobiasz Cudnik

Status: review_failedreview

I'm including changes for all skins.

comment:8 Changed 9 years ago by Garry Yao

Status: reviewreview_passed

Changed 9 years ago by Tobiasz Cudnik

Attachment: 6820_3.patch added

comment:9 Changed 9 years ago by Tobiasz Cudnik

Resolution: fixed
Status: review_passedclosed

Fixed with [6218].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy